# Makefile.in --
#
#	This file is a Makefile for Sample TEA Extension.  If it has the name
#	"Makefile.in" then it is a template for a Makefile;  to generate the
#	actual Makefile, run "./configure", which is a configuration script
#	generated by the "autoconf" program (constructs like "@foo@" will get
#	replaced in the actual Makefile.
#
# Copyright (c) 1999 Scriptics Corporation.
#
# See the file "license.terms" for information on usage and redistribution
# of this file, and for a DISCLAIMER OF ALL WARRANTIES.
#
# RCS: @(#) $Id: Makefile.in,v 1.11 2006/12/20 21:38:04 tkgeomap Exp $

#========================================================================
# Edit the following few lines when writing a new extension
#========================================================================

#========================================================================
# Change the name of the variable "exampleA_LIB_FILE" to match the one
# used in the configure script.  This is the parameterized name of the
# library that we are building.
#========================================================================

lib_BINARIES=$(tclgeomap_LIB_FILE)
BINARIES=$(lib_BINARIES)

#========================================================================
# Enumerate the names of the source files included in this package.
# This will be used when a dist target is added to the Makefile.
#========================================================================

TOP_DIR = $(srcdir)/..
GENERIC_DIR = $(TOP_DIR)/generic
TCL_DIR = $(TOP_DIR)/tcl
tclgeomap_SOURCES = $(TCL_DIR)/tclgeomap.c \
		    $(TCL_DIR)/tclgeomapLnArr.c \
		    $(TCL_DIR)/tclgeomapPlace.c \
		    $(TCL_DIR)/tclgeomapTime.c \
		    $(TCL_DIR)/tclgeomapProj.c \
		    $(GENERIC_DIR)/geoLnArrToMap.c $(GENERIC_DIR)/geoProj.c \
		    $(GENERIC_DIR)/geoLines.c $(GENERIC_DIR)/mapLines.c \
		    $(GENERIC_DIR)/geoTime.c \
		    $(GENERIC_DIR)/geography.c
SOURCES = $(tclgeomap_SOURCES)

#========================================================================
# Enumerate the names of the object files included in this package.
# These objects are created and linked into the final library.  In
# most cases these object files will correspond to the source files
# above.
#
#========================================================================

tclgeomap_OBJECTS = tclgeomap.o tclgeomapLnArr.o tclgeomapPlace.o \
		    tclgeomapTime.o tclgeomapProj.o \
		    geoLnArrToMap.o geoProj.o geoLines.o \
		    mapLines.o geoTime.o geography.o
PKG_OBJECTS = $(tclgeomap_OBJECTS)

#========================================================================
# The substitution of "exampleA_LIB_FILE" into the variable name below
# let's us refer to the objects for the library without knowing the name
# of the library in advance.  It also lets us use the "$@" variable in
# the rule for building the library, so we can refer to both the list of 
# objects and the library itself in a platform-independent manner.
#========================================================================

tclgeomap_LIB_FILE = @tclgeomap_LIB_FILE@
$(tclgeomap_LIB_FILE)_OBJECTS = $(tclgeomap_OBJECTS)

#========================================================================
# This is a list of header files to be installed
#========================================================================

GENERIC_HDRS= \
	$(GENERIC_DIR)/geoLines.h $(GENERIC_DIR)/geoLnArrToMap.h \
	$(GENERIC_DIR)/geoProj.h $(GENERIC_DIR)/geography.h \
	$(GENERIC_DIR)/mapLines.h $(TCL_DIR)/tclgeomap.h

#========================================================================
# Add additional lines to handle any additional AC_SUBST cases that
# have been added to the configure script.
#========================================================================

SAMPLE_NEW_VAR=@SAMPLE_NEW_VAR@

#========================================================================
# Nothing of the variables below this line need to be changed.  Please
# check the TARGETS section below to make sure the make targets are
# correct.
#========================================================================

SHELL = @SHELL@

srcdir = @srcdir@
top_srcdir = @top_srcdir@
prefix = @prefix@
exec_prefix = @exec_prefix@

bindir = @bindir@
sbindir = @sbindir@
libexecdir = @libexecdir@
datadir = @datadir@
sysconfdir = @sysconfdir@
sharedstatedir = @sharedstatedir@
localstatedir = @localstatedir@
libdir = @libdir@
pkglibdir = @pkglibdir@
infodir = @infodir@
mandir = @mandir@
includedir = @includedir@
oldincludedir = /usr/include

# Directory in which to install manual entries for Tcl's C library
# procedures:
MAN3_INSTALL_DIR	= $(mandir)/man3

# Directory in which to install manual entries for the built-in
# Tcl commands:
MANN_INSTALL_DIR	= $(mandir)/mann

pkgdatadir = $(datadir)/@PACKAGE_NAME@
pkgincludedir = $(includedir)/@PACKAGE_NAME@

# Path to use at runtime to refer to LIB_INSTALL_DIR:
LIB_RUNTIME_DIR		= $(libdir)

# support for embedded libraries on Darwin / Mac OS X
DYLIB_INSTALL_DIR	= ${LIB_RUNTIME_DIR}

top_builddir = .

INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
INSTALL_SCRIPT = @INSTALL_SCRIPT@
INSTALL_STRIP_FLAG =
transform = @program_transform_name@

NORMAL_INSTALL = :
PRE_INSTALL = :
POST_INSTALL = :
NORMAL_UNINSTALL = :
PRE_UNINSTALL = :
POST_UNINSTALL = :

PACKAGE_NAME = @PACKAGE_NAME@
PACKAGE_VERSION = 
CC = @CC@
CFLAGS_DEBUG = @CFLAGS_DEBUG@
CFLAGS_DEFAULT = @CFLAGS_DEFAULT@
CFLAGS_OPTIMIZE = @CFLAGS_OPTIMIZE@
CLEANFILES = @CLEANFILES@
EXEEXT = @EXEEXT@
LDFLAGS_DEBUG = @LDFLAGS_DEBUG@
LDFLAGS_DEFAULT = @LDFLAGS_DEFAULT@
LDFLAGS_OPTIMIZE = @LDFLAGS_OPTIMIZE@
MAKE_LIB = @MAKE_LIB@
MAKE_SHARED_LIB = @MAKE_SHARED_LIB@
MAKE_STATIC_LIB = @MAKE_STATIC_LIB@
OBJEXT = @OBJEXT@
RANLIB = @RANLIB@
SHLIB_CFLAGS = @SHLIB_CFLAGS@
SHLIB_LD = @SHLIB_LD@
SHLIB_LDFLAGS = @SHLIB_LDFLAGS@
SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
TCL_SHLIB_LD_EXTRAS = @TCL_SHLIB_LD_EXTRAS@
STLIB_LD = @STLIB_LD@
TCL_BIN_DIR = @TCL_BIN_DIR@
TCL_DEFS = @TCL_DEFS@
TCL_EXTRA_CFLAGS = @TCL_EXTRA_CFLAGS@
TCL_LD_FLAGS = @TCL_LD_FLAGS@
TCL_LIBS = @TCL_LIBS@
TCL_SHLIB_LD_LIBS = @TCL_SHLIB_LD_LIBS@
TCL_SRC_DIR = @TCL_SRC_DIR@
TCL_DBGX = @TCL_DBGX@
TCL_STUB_LIB_FILE = @TCL_STUB_LIB_FILE@
TCL_STUB_LIB_SPEC = @TCL_STUB_LIB_SPEC@
TCL_TOOL_DIR_NATIVE = @TCL_TOOL_DIR_NATIVE@
TCL_TOP_DIR_NATIVE = @TCL_TOP_DIR_NATIVE@
TCL_UNIX_DIR_NATIVE = @TCL_UNIX_DIR_NATIVE@
TCL_WIN_DIR_NATIVE = @TCL_WIN_DIR_NATIVE@
INCLUDE_DIR_NATIVE = @INCLUDE_DIR_NATIVE@
TCL_BMAP_DIR_NATIVE = @TCL_BMAP_DIR_NATIVE@
TCL_PLATFORM_DIR_NATIVE = @TCL_PLATFORM_DIR_NATIVE@
TCL_GENERIC_DIR_NATIVE = @TCL_GENERIC_DIR_NATIVE@
TCLSH_PROG = @TCLSH_PROG@

AUTOCONF = autoconf

LDFLAGS = $(LDFLAGS_DEFAULT)

INCLUDES = @TCL_INCLUDES@ -I$(GENERIC_DIR) -I$(TCL_DIR)

EXTRA_CFLAGS = $(TCL_DEFS) $(PROTO_FLAGS) $(SECURITY_FLAGS) $(MEM_DEBUG_FLAGS) $(KEYSYM_FLAGS) $(NO_DEPRECATED_FLAGS) @PACKAGE_CFLAGS@

DEFS = @DEFS@ $(EXTRA_CFLAGS)

ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_CLEAN_FILES = pkgIndex.tcl

CPPFLAGS = @CPPFLAGS@
LIBS = @LIBS@
AR = ar
CFLAGS = @CFLAGS@
COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -DUSE_COMPAT_CONST
CCLD = $(CC)
LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@

#========================================================================
# Start of user-definable TARGETS section
#========================================================================

#========================================================================
# TEA TARGETS.  Please note that the "libraries:" target refers to platform
# independent files, and the "binaries:" target inclues executable programs and
# platform-dependent libraries.  Modify these targets so that they install
# the various pieces of your package.  The make and install rules
# for the BINARIES that you specified above have already been done.
#========================================================================

all: libraries binaries doc

#========================================================================
# The binaries target builds executable programs, Windows .dll's, unix
# shared/static libraries, and any other platform-dependent files.
# The list of targets to build for "binaries:" is specified at the top
# of the Makefile, in the "BINARIES" variable.
#========================================================================

binaries: $(BINARIES)

libraries:

doc:

install: all install-libraries install-binaries install-doc

install-binaries: binaries install-lib-binaries install-bin-binaries

#========================================================================
# This rule installs platform-independent files, such as header files.
#========================================================================

install-libraries: libraries
	$(mkinstalldirs) $(includedir)
	$(mkinstalldirs) $(pkgincludedir)
	echo "Installing header files in $(pkgincludedir)"
	@for i in $(GENERIC_HDRS) ; do \
	    echo "Installing $$i" ; \
	    $(INSTALL_DATA) $$i $(pkgincludedir) ; \
	done;
	@for i in `ls $(pkgincludedir)` ; do \
	    rm -f $(includedir)/$$i ; \
	done;
	echo Making $(pkglibdir)
	$(mkinstalldirs) $(pkglibdir)
	echo "Installing tclgeomap_procs.tcl in $(pkglibdir)"
	$(INSTALL_DATA) $(TOP_DIR)/library/tclgeomap_procs.tcl $(pkglibdir)

#========================================================================
# Install documentation.  Unix manpages should go in the $(mandir)
# directory.
#========================================================================

install-doc: doc
	@if test ! -x $(srcdir)/mkLinks; then \
	    chmod +x $(srcdir)/mkLinks; \
	    fi
	@for i in $(mandir) $(MAN3_INSTALL_DIR) $(MANN_INSTALL_DIR) ; \
	    do \
	    if [ ! -d $$i ] ; then \
		echo "Making directory $$i"; \
		mkdir -p $$i; \
		chmod 755 $$i; \
		else true; \
		fi; \
	    done;
	@echo "Installing C API (.3) docs";
	@cd $(TOP_DIR)/doc; for i in *.3; \
	    do \
	    rm -f $(MAN3_INSTALL_DIR)/$$i; \
	    sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
		    $$i > $(MAN3_INSTALL_DIR)/$$i; \
	    chmod 444 $(MAN3_INSTALL_DIR)/$$i; \
	    done;
	@echo "Cross-linking C API (.3) docs";
	@$(srcdir)/mkLinks $(MKLINKS_FLAGS) $(MAN3_INSTALL_DIR)
	@echo "Installing command (.n) docs";
	@cd $(TOP_DIR)/doc; for i in *.n; \
	    do \
	    rm -f $(MANN_INSTALL_DIR)/$$i; \
	    sed -e '/man\.macros/r man.macros' -e '/man\.macros/d' \
		    $$i > $(MANN_INSTALL_DIR)/$$i; \
	    chmod 444 $(MANN_INSTALL_DIR)/$$i; \
	    done;
	@echo "Cross-linking command (.n) docs";
	@$(srcdir)/mkLinks $(MKLINKS_FLAGS) $(MANN_INSTALL_DIR)

test:

depend:

#========================================================================
# Enumerate the names of the object files included in this package.
# These objects are created and linked into the final library.  In
# most cases these object files will correspond to the source files
# above.
#
# $(exampleA_LIB_FILE) should be listed as part of the BINARIES variable
# at the top of the Makefile.  That will ensure that this target is built
# when you run "make binaries".
#
# You shouldn't need to modify this target, except to change the package
# name from "exampleA" to your package's name.
#========================================================================

$(tclgeomap_LIB_FILE): $(tclgeomap_OBJECTS)
	-rm -f $(tclgeomap_LIB_FILE)
	@MAKE_LIB@
	$(RANLIB) $(tclgeomap_LIB_FILE)

#========================================================================
# We need to enumerate the list of .c to .o lines here.
# Unfortunately, there does not seem to be any other way to do this
# in a Makefile-independent way.  We can't use VPATH because it picks up
# object files that may be located in the source directory.
#
# In the following lines, $(srcdir) refers to the toplevel directory
# containing your extension.  If your sources are in a subdirectory,
# you will have to modify the paths to reflect this:
#
# exampleA.$(OBJEXT): $(srcdir)/src/win/exampleA.c
# 	$(COMPILE) -c `@CYGPATH@ $(srcdir)/src/win/exampleA.c` -o $@
#========================================================================

tclgeomapLnArr.o : $(TCL_DIR)/tclgeomapLnArr.c $(TCL_DIR)/tclgeomapInt.h \
    $(TCL_DIR)/tclgeomap.h $(GENERIC_DIR)/geography.h \
    $(GENERIC_DIR)/geoLines.h $(GENERIC_DIR)/mapLines.h
	$(COMPILE) -c `@CYGPATH@ $(TCL_DIR)/tclgeomapLnArr.c` -o $@

tclgeomap.o : $(TCL_DIR)/tclgeomap.c $(TCL_DIR)/tclgeomap.h \
    $(TCL_DIR)/tclgeomapInt.h
	$(COMPILE) -c `@CYGPATH@ $(TCL_DIR)/tclgeomap.c` -o $@

tclgeomapTime.o : $(TCL_DIR)/tclgeomapTime.c $(TCL_DIR)/tclgeomap.h \
    $(GENERIC_DIR)/geography.h
	$(COMPILE) -c `@CYGPATH@ $(TCL_DIR)/tclgeomapTime.c` -o $@

tclgeomapPlace.o : $(TCL_DIR)/tclgeomapPlace.c $(TCL_DIR)/tclgeomap.h \
    $(GENERIC_DIR)/geography.h
	$(COMPILE) -c `@CYGPATH@ $(TCL_DIR)/tclgeomapPlace.c` -o $@

tclgeomapProj.o : $(TCL_DIR)/tclgeomapProj.c $(GENERIC_DIR)/geoProj.h \
    $(TCL_DIR)/tclgeomapInt.h $(TCL_DIR)/tclgeomap.h
	$(COMPILE) -c `@CYGPATH@ $(TCL_DIR)/tclgeomapProj.c` -o $@

geoProj.o : $(GENERIC_DIR)/geoProj.c $(GENERIC_DIR)/geography.h \
    $(GENERIC_DIR)/geoProj.h
	$(COMPILE) -c `@CYGPATH@ $(GENERIC_DIR)/geoProj.c` -o $@

geoLines.o : $(GENERIC_DIR)/geoLines.c $(GENERIC_DIR)/geography.h \
    $(GENERIC_DIR)/geoLines.h
	$(COMPILE) -c `@CYGPATH@ $(GENERIC_DIR)/geoLines.c` -o $@

mapLines.o : $(GENERIC_DIR)/mapLines.c $(GENERIC_DIR)/geography.h \
    $(GENERIC_DIR)/geoLines.h
	$(COMPILE) -c `@CYGPATH@ $(GENERIC_DIR)/mapLines.c` -o $@

geoLnArrToMap.o : $(GENERIC_DIR)/geoLnArrToMap.c $(GENERIC_DIR)/geography.h \
    $(GENERIC_DIR)/geoLines.h $(GENERIC_DIR)/mapLines.h \
    $(GENERIC_DIR)/geoProj.h $(GENERIC_DIR)/geoLnArrToMap.h
	$(COMPILE) -c `@CYGPATH@ $(GENERIC_DIR)/geoLnArrToMap.c` -o $@

geoTime.o : $(GENERIC_DIR)/geoTime.c $(GENERIC_DIR)/geography.h
	$(COMPILE) -c `@CYGPATH@ $(GENERIC_DIR)/geoTime.c` -o $@

geography.o : $(GENERIC_DIR)/geography.c $(GENERIC_DIR)/geography.h
	$(COMPILE) -c `@CYGPATH@ $(GENERIC_DIR)/geography.c` -o $@

#========================================================================
# End of user-definable section
#========================================================================

#========================================================================
# Don't modify the file to clean here.  Instead, set the "CLEANFILES"
# variable in configure.in
#========================================================================

clean:  
	-test -z "$(BINARIES)" || rm -f $(BINARIES)
	-rm -f *.o core *.core
	-rm -f *.$(OBJEXT)
	-test -z "$(CLEANFILES)" || rm -f $(CLEANFILES)

distclean: clean
	-rm -f *.tab.c
	-rm -f Makefile $(CONFIG_CLEAN_FILES)
	-rm -f config.cache config.log stamp-h stamp-h[0-9]*
	-rm -f config.status

#========================================================================
# Install binary object libraries.  On Windows this includes both .dll and
# .lib files.  Because the .lib files are not explicitly listed anywhere,
# we need to deduce their existence from the .dll file of the same name.
# Additionally, the .dll files go into the bin directory, but the .lib
# files go into the lib directory.  On Unix platforms, all library files
# go into the lib directory.  In addition, this will generate the pkgIndex.tcl
# file in the install location (assuming it can find a usable tclsh8.2 shell)
#
# You should not have to modify this target.
#========================================================================

install-lib-binaries: installdirs
	@list='$(lib_BINARIES)'; for p in $$list; do \
	  if test -f $$p; then \
	    ext=`echo $$p|sed -e "s/.*\.//"`; \
	    if test "x$$ext" = "xdll"; then \
	        echo " $(INSTALL_DATA) $$p $(bindir)/$$p"; \
	        $(INSTALL_DATA) $$p $(bindir)/$$p; \
		lib=`basename $$p|sed -e 's/.[^.]*$$//'`.lib; \
		if test -f $$lib; then \
		    echo " $(INSTALL_DATA) $$lib $(libdir)/$$lib"; \
	            $(INSTALL_DATA) $$lib $(libdir)/$$lib; \
		fi; \
	    else \
		echo " $(INSTALL_DATA) $$p $(libdir)/$$p"; \
	        $(INSTALL_DATA) $$p $(libdir)/$$p; \
	    fi; \
	  else :; fi; \
	done
	@list='$(lib_BINARIES)'; for p in $$list; do \
	  if test -f $$p; then \
	    echo " $(RANLIB) $(libdir)/$$p"; \
	    $(RANLIB) $(libdir)/$$p; \
	  else :; fi; \
	done
	$(INSTALL_DATA) pkgIndex.tcl $(pkglibdir)

#========================================================================
# Install binary executables (e.g. .exe files)
#
# You should not have to modify this target.
#========================================================================

install-bin-binaries: installdirs
	@list='$(bin_BINARIES)'; for p in $$list; do \
	  if test -f $$p; then \
	    echo " $(INSTALL_DATA) $$p $(bindir)/$$p"; \
	    $(INSTALL_DATA) $$p $(bindir)/$$p; \
	  else :; fi; \
	done

.SUFFIXES: .c .o .obj

Makefile: $(srcdir)/Makefile.in  $(top_builddir)/config.status
	cd $(top_builddir) \
	  && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status

config.status: $(srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
	$(SHELL) ./config.status --recheck
$(srcdir)/configure: $(srcdir)/configure.in $(ACLOCAL_M4) $(CONFIGURE_DEPENDENCIES)
	cd $(srcdir) && $(AUTOCONF)


uninstall-binaries:
	@$(NORMAL_UNINSTALL)
	list='$(BINARIES)'; for p in $$list; do \
	  rm -f $(libdir)/$$p; \
	done

installdirs:
	$(mkinstalldirs)  $(libdir)
	$(mkinstalldirs)  $(bindir)
	$(mkinstalldirs)  $(pkglibdir)

.PHONY: all binaries clean depend distclean doc install installdirs \
libraries test

# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:


syntax highlighted by Code2HTML, v. 0.9.1