# ex:ts=8
# Ports collection makefile for:	autobench
# Date created:			Oct 20, 2003
# Whom:				ijliao
#
# $FreeBSD: ports/benchmarks/autobench/Makefile,v 1.7 2007/05/19 20:00:19 flz Exp $
#

PORTNAME=	autobench
PORTVERSION=	2.1.2
PORTREVISION=	1
CATEGORIES=	benchmarks www
MASTER_SITES=	http://www.xenoclast.org/autobench/downloads/

MAINTAINER=	ports@FreeBSD.org
COMMENT=	Automating the process of benchmarking a web server

RUN_DEPENDS=	httperf:${PORTSDIR}/benchmarks/httperf \
		gawk:${PORTSDIR}/lang/gawk \
		gnuplot:${PORTSDIR}/math/gnuplot

USE_PERL5=	yes
USE_GMAKE=	yes
MAKE_ARGS=	CC="${CC}" CFLAGS="${CFLAGS}" DEBUG_FLAGS= \
		PREFIX=${PREFIX}

MAN1=	autobench.1 autobench_admin.1 autobenchd.1 bench2graph.1 \
	crfile.1 sesslog.1

post-patch:
.for file in autobench autobench_admin
	@${PERL} -pi -e "s|/etc/|${PREFIX}/etc/|g" ${WRKSRC}/${file}
.endfor

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1