# New ports collection makefile for: p5-Benchmark-Stopwatch
# Date created: 2006-08-24
# Whom: Gea-Suan Lin <gslin@gslin.org>
#
# $FreeBSD: ports/benchmarks/p5-Benchmark-Stopwatch/Makefile,v 1.3 2007/10/05 01:08:51 clsung Exp $
#
PORTNAME= Benchmark-Stopwatch
PORTVERSION= 0.05
CATEGORIES= benchmarks perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Benchmark
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple timing of stages of your code
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Clone.pm:${PORTSDIR}/devel/p5-Clone
BUILD_DEPENDS= ${RUN_DEPENDS}
BUILD_DEPENDS+= ${SITE_PERL}/Test/LongString.pm:${PORTSDIR}/devel/p5-Test-LongString
PERL_CONFIGURE= yes
MAN3= Benchmark::Stopwatch.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500703
RUN_DEPENDS+= ${SITE_PERL}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
.endif
.include <bsd.port.post.mk>
syntax highlighted by Code2HTML, v. 0.9.1