#
# This is a generated file. Modifications are futile.
#

.SUFFIXES:
.SUFFIXES: .h .cc .obj .lib

STD_INCLUDE = /I"\Program Files\Microsoft Visual Studio\VC98\INCLUDE"
LCL_INCLUDE = /I../.. /I..
INCLUDE     = $(LCL_INCLUDE) $(STD_INCLUDE)

DEFINES = /DHAVE_CONFIG_H

#CXX     = 
CXXFLAGS = /nologo /MLd /W3 /GX /Zi /O2 /DWIN32 /DNDEBUG /D_CONSOLE /D_MBCS /TP $(INCLUDE) $(DEFINES)
CCFLAGS  = $(CXXFLAGS)

RANLIB = echo
AR_R   = link.exe -lib
LINK   = link.exe

LDFLAGS  = /nologo
LIBS     = kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib ws2_32.lib
EXEFLAGS = $(LDFLAGS) /subsystem:console /incremental:no /debug /machine:I386 $(LIBS)

SUBDIRS = 

default: all

AggrStat.cc: polygraph.h ILog.h OLog.h AggrStat.h

AggrStat.h: OLog.h ILog.h

AggrStat.obj: AggrStat.cc
	$(CXX) /FoAggrStat.obj -c AggrStat.cc $(CXXFLAGS)

BStream.cc: polygraph.h BStream.h

BStream.obj: BStream.cc
	$(CXX) /FoBStream.obj -c BStream.cc $(CXXFLAGS)

CmdLine.cc: polygraph.h Opt.h CmdLine.h

CmdLine.obj: CmdLine.cc
	$(CXX) /FoCmdLine.obj -c CmdLine.cc $(CXXFLAGS)

ConnCloseStat.cc: polygraph.h ConnCloseStat.h

ConnCloseStat.h: LogObj.h histograms.h

ConnCloseStat.obj: ConnCloseStat.cc
	$(CXX) /FoConnCloseStat.obj -c ConnCloseStat.cc $(CXXFLAGS)

ContTypeStat.cc: polygraph.h AggrStat.h ContTypeStat.h

ContTypeStat.h: LogObj.h

ContTypeStat.obj: ContTypeStat.cc
	$(CXX) /FoContTypeStat.obj -c ContTypeStat.cc $(CXXFLAGS)

ErrorHash.cc: polygraph.h ErrorRec.h ILog.h OLog.h ErrorHash.h

ErrorHash.obj: ErrorHash.cc
	$(CXX) /FoErrorHash.obj -c ErrorHash.cc $(CXXFLAGS)

ErrorRec.cc: polygraph.h ILog.h OLog.h ErrorRec.h

ErrorRec.h: LogObj.h

ErrorRec.obj: ErrorRec.cc
	$(CXX) /FoErrorRec.obj -c ErrorRec.cc $(CXXFLAGS)

ErrorStat.cc: polygraph.h ILog.h OLog.h ErrorRec.h ErrorHash.h ErrorStat.h

ErrorStat.h: LogObj.h

ErrorStat.obj: ErrorStat.cc
	$(CXX) /FoErrorStat.obj -c ErrorStat.cc $(CXXFLAGS)

GoalRec.cc: polygraph.h ILog.h OLog.h GoalRec.h

GoalRec.h: LogObj.h

GoalRec.obj: GoalRec.cc
	$(CXX) /FoGoalRec.obj -c GoalRec.cc $(CXXFLAGS)

HRHistStat.cc: polygraph.h ILog.h OLog.h HRHistStat.h

HRHistStat.h: TmSzHistStat.h

HRHistStat.obj: HRHistStat.cc
	$(CXX) /FoHRHistStat.obj -c HRHistStat.cc $(CXXFLAGS)

HRStat.cc: polygraph.h ILog.h OLog.h HRStat.h

HRStat.h: TmSzStat.h

HRStat.obj: HRStat.cc
	$(CXX) /FoHRStat.obj -c HRStat.cc $(CXXFLAGS)

Histogram.cc: polygraph.h ILog.h OLog.h Histogram.h

Histogram.h: AggrStat.h ILog.h OLog.h LogObj.h

Histogram.obj: Histogram.cc
	$(CXX) /FoHistogram.obj -c Histogram.cc $(CXXFLAGS)

ILog.cc: polygraph.h ILog.h polyLogCats.h polyLogTags.h

ILog.h: Progress.h

ILog.obj: ILog.cc
	$(CXX) /FoILog.obj -c ILog.cc $(CXXFLAGS)

IcpStat.cc: polygraph.h ILog.h OLog.h IcpStat.h

IcpStat.h: HRStat.h

IcpStat.obj: IcpStat.cc
	$(CXX) /FoIcpStat.obj -c IcpStat.cc $(CXXFLAGS)

LevelStat.cc: polygraph.h ILog.h OLog.h LevelStat.h

LevelStat.obj: LevelStat.cc
	$(CXX) /FoLevelStat.obj -c LevelStat.cc $(CXXFLAGS)

LogObj.h: OLog.h ILog.h

OLog.cc: polygraph.h OLog.h

OLog.obj: OLog.cc
	$(CXX) /FoOLog.obj -c OLog.cc $(CXXFLAGS)

ObjId.cc: polygraph.h OLog.h ILog.h ObjId.h

ObjId.h: UniqId.h

ObjId.obj: ObjId.cc
	$(CXX) /FoObjId.obj -c ObjId.cc $(CXXFLAGS)

ObjTimes.cc: polygraph.h OLog.h ObjTimes.h

ObjTimes.obj: ObjTimes.cc
	$(CXX) /FoObjTimes.obj -c ObjTimes.cc $(CXXFLAGS)

OidGenStat.cc: polygraph.h ILog.h OLog.h OidGenStat.h

OidGenStat.obj: OidGenStat.cc
	$(CXX) /FoOidGenStat.obj -c OidGenStat.cc $(CXXFLAGS)

Opt.cc: polygraph.h Opt.h

Opt.obj: Opt.cc
	$(CXX) /FoOpt.obj -c Opt.cc $(CXXFLAGS)

Progress.cc: polygraph.h OLog.h ILog.h Progress.h

Progress.obj: Progress.cc
	$(CXX) /FoProgress.obj -c Progress.cc $(CXXFLAGS)

RndPermut.cc: polygraph.h RndPermut.h

RndPermut.obj: RndPermut.cc
	$(CXX) /FoRndPermut.obj -c RndPermut.cc $(CXXFLAGS)

SslIntvlStat.cc: polygraph.h ILog.h OLog.h SslIntvlStat.h

SslIntvlStat.h: HRStat.h LevelStat.h

SslIntvlStat.obj: SslIntvlStat.cc
	$(CXX) /FoSslIntvlStat.obj -c SslIntvlStat.cc $(CXXFLAGS)

StatIntvlRec.cc: polygraph.h ILog.h OLog.h StatIntvlRec.h

StatIntvlRec.h: LogObj.h IcpStat.h SslIntvlStat.h

StatIntvlRec.obj: StatIntvlRec.cc
	$(CXX) /FoStatIntvlRec.obj -c StatIntvlRec.cc $(CXXFLAGS)

StatPhaseRec.cc: polygraph.h StatPhaseRec.h OLog.h ILog.h

StatPhaseRec.h: StatIntvlRec.h GoalRec.h ContTypeStat.h ConnCloseStat.h HRHistStat.h ErrorStat.h OidGenStat.h histograms.h

StatPhaseRec.obj: StatPhaseRec.cc
	$(CXX) /FoStatPhaseRec.obj -c StatPhaseRec.cc $(CXXFLAGS)

StringArray.cc: polygraph.h StringArrayBlocks.h StringArray.h

StringArray.obj: StringArray.cc
	$(CXX) /FoStringArray.obj -c StringArray.cc $(CXXFLAGS)

StringArrayBlocks.cc: polygraph.h StringArrayBlocks.h

StringArrayBlocks.obj: StringArrayBlocks.cc
	$(CXX) /FoStringArrayBlocks.obj -c StringArrayBlocks.cc $(CXXFLAGS)

StringRange.cc: polygraph.h StringRangeBlocks.h StringRange.h

StringRange.h: StringArrayBlocks.h

StringRange.obj: StringRange.cc
	$(CXX) /FoStringRange.obj -c StringRange.cc $(CXXFLAGS)

StringRangeBlocks.cc: polygraph.h StringRangeBlocks.h

StringRangeBlocks.obj: StringRangeBlocks.cc
	$(CXX) /FoStringRangeBlocks.obj -c StringRangeBlocks.cc $(CXXFLAGS)

TmSzHistStat.cc: polygraph.h ILog.h OLog.h TmSzHistStat.h

TmSzHistStat.h: TmSzStat.h histograms.h

TmSzHistStat.obj: TmSzHistStat.cc
	$(CXX) /FoTmSzHistStat.obj -c TmSzHistStat.cc $(CXXFLAGS)

TmSzStat.cc: polygraph.h ILog.h OLog.h TmSzStat.h

TmSzStat.h: AggrStat.h

TmSzStat.obj: TmSzStat.cc
	$(CXX) /FoTmSzStat.obj -c TmSzStat.cc $(CXXFLAGS)

TwoWayPermutator.cc: polygraph.h RndPermut.h TwoWayPermutator.h

TwoWayPermutator.obj: TwoWayPermutator.cc
	$(CXX) /FoTwoWayPermutator.obj -c TwoWayPermutator.cc $(CXXFLAGS)

UniqId.cc: polygraph.h ILog.h OLog.h BStream.h UniqId.h

UniqId.obj: UniqId.cc
	$(CXX) /FoUniqId.obj -c UniqId.cc $(CXXFLAGS)

XactStatRec.cc: polygraph.h OLog.h ILog.h XactStatRec.h

XactStatRec.h: ObjId.h

XactStatRec.obj: XactStatRec.cc
	$(CXX) /FoXactStatRec.obj -c XactStatRec.cc $(CXXFLAGS)

base.lib: BStream.obj CmdLine.obj StringRangeBlocks.obj StringRange.obj StringArrayBlocks.obj StringArray.obj ErrorRec.obj ErrorHash.obj Histogram.obj AggrStat.obj LevelStat.obj HRHistStat.obj TmSzHistStat.obj TmSzStat.obj HRStat.obj IcpStat.obj ConnCloseStat.obj ContTypeStat.obj ErrorStat.obj OidGenStat.obj SslIntvlStat.obj GoalRec.obj ILog.obj ObjTimes.obj ObjId.obj OLog.obj Opt.obj Progress.obj RndPermut.obj TwoWayPermutator.obj UniqId.obj StatIntvlRec.obj StatPhaseRec.obj XactStatRec.obj histograms.obj opts.obj polyOpts.obj rndDistrStat.obj loadTblDistr.obj polyVersion.obj
	-erase /F $@
	$(AR_R) $(LDFLAGS) /out:$@ \
	BStream.obj CmdLine.obj StringRangeBlocks.obj StringRange.obj StringArrayBlocks.obj StringArray.obj ErrorRec.obj ErrorHash.obj Histogram.obj AggrStat.obj LevelStat.obj HRHistStat.obj TmSzHistStat.obj TmSzStat.obj HRStat.obj IcpStat.obj ConnCloseStat.obj ContTypeStat.obj ErrorStat.obj OidGenStat.obj SslIntvlStat.obj GoalRec.obj ILog.obj ObjTimes.obj ObjId.obj OLog.obj Opt.obj Progress.obj RndPermut.obj TwoWayPermutator.obj UniqId.obj StatIntvlRec.obj StatPhaseRec.obj XactStatRec.obj histograms.obj opts.obj polyOpts.obj rndDistrStat.obj loadTblDistr.obj polyVersion.obj

histograms.cc: polygraph.h ILog.h OLog.h histograms.h

histograms.h: Histogram.h

histograms.obj: histograms.cc
	$(CXX) /Fohistograms.obj -c histograms.cc $(CXXFLAGS)

loadTblDistr.cc: polygraph.h loadTblDistr.h

loadTblDistr.obj: loadTblDistr.cc
	$(CXX) /FoloadTblDistr.obj -c loadTblDistr.cc $(CXXFLAGS)

opts.cc: polygraph.h UniqId.h CmdLine.h loadTblDistr.h opts.h

opts.h: Progress.h Opt.h

opts.obj: opts.cc
	$(CXX) /Foopts.obj -c opts.cc $(CXXFLAGS)

polyOpts.cc: polygraph.h opts.h polyOpts.h polyVersion.h

polyOpts.h: opts.h

polyOpts.obj: polyOpts.cc
	$(CXX) /FopolyOpts.obj -c polyOpts.cc $(CXXFLAGS)

polyVersion.cc: polygraph.h polyVersion.h

polyVersion.obj: polyVersion.cc
	$(CXX) /FopolyVersion.obj -c polyVersion.cc $(CXXFLAGS)

rndDistrStat.cc: polygraph.h AggrStat.h

rndDistrStat.h: AggrStat.h

rndDistrStat.obj: rndDistrStat.cc
	$(CXX) /ForndDistrStat.obj -c rndDistrStat.cc $(CXXFLAGS)

all: all_subdirs base.lib

all_subdirs: 

clean: clean_subdirs 
	-erase /F *.obj *.lib core base.lib

clean_subdirs: 

distclean: distclean_subdirs 
	-erase /F *.obj *.lib core base.lib

distclean_subdirs: 

install: install_subdirs base.lib

install_subdirs: 

semiclean: semiclean_subdirs 
	-erase /F base.lib core

semiclean_subdirs: 



syntax highlighted by Code2HTML, v. 0.9.1