#
# This is a generated file. Modifications are futile.
#

.SUFFIXES:
.SUFFIXES: .h .cc .obj .lib

STD_INCLUDE = /I"\Program Files\Microsoft Visual Studio\VC98\INCLUDE"
LCL_INCLUDE = /I../.. /I..
INCLUDE     = $(LCL_INCLUDE) $(STD_INCLUDE)

DEFINES = /DHAVE_CONFIG_H

#CXX     = 
CXXFLAGS = /nologo /MLd /W3 /GX /Zi /O2 /DWIN32 /DNDEBUG /D_CONSOLE /D_MBCS /TP $(INCLUDE) $(DEFINES)
CCFLAGS  = $(CXXFLAGS)

RANLIB = echo
AR_R   = link.exe -lib
LINK   = link.exe

LDFLAGS  = /nologo
LIBS     = kernel32.lib user32.lib gdi32.lib winspool.lib comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib ws2_32.lib
EXEFLAGS = $(LDFLAGS) /subsystem:console /incremental:no /debug /machine:I386 $(LIBS)

SUBDIRS = 

default: all

Cache.cc: DistrPoint.h CacheEntry.h CacheEntryHash.h CachePolicy.h Cache.h

Cache.h: CacheEntry.h

Cache.obj: Cache.cc
	$(CXX) /FoCache.obj -c Cache.cc $(CXXFLAGS)

CacheEntry.cc: DistrPoint.h CacheEntry.h Cache.h

CacheEntry.obj: CacheEntry.cc
	$(CXX) /FoCacheEntry.obj -c CacheEntry.cc $(CXXFLAGS)

CacheEntryHash.cc: CacheEntry.h CacheEntryHash.h

CacheEntryHash.obj: CacheEntryHash.cc
	$(CXX) /FoCacheEntryHash.obj -c CacheEntryHash.cc $(CXXFLAGS)

CachePolicy.cc: CachePolicy.h

CachePolicy.h: CacheEntry.h

CachePolicy.obj: CachePolicy.cc
	$(CXX) /FoCachePolicy.obj -c CachePolicy.cc $(CXXFLAGS)

DistrPoint.cc: CacheEntry.h Cache.h DistrPoint.h

DistrPoint.obj: DistrPoint.cc
	$(CXX) /FoDistrPoint.obj -c DistrPoint.cc $(CXXFLAGS)

cache.lib: Cache.obj CacheEntry.obj CacheEntryHash.obj CachePolicy.obj DistrPoint.obj
	-erase /F $@
	$(AR_R) $(LDFLAGS) /out:$@ \
	Cache.obj CacheEntry.obj CacheEntryHash.obj CachePolicy.obj DistrPoint.obj

all: all_subdirs cache.lib

all_subdirs: 

clean: clean_subdirs 
	-erase /F *.obj *.lib core cache.lib

clean_subdirs: 

distclean: distclean_subdirs 
	-erase /F *.obj *.lib core cache.lib

distclean_subdirs: 

install: install_subdirs cache.lib

install_subdirs: 

semiclean: semiclean_subdirs 
	-erase /F cache.lib core

semiclean_subdirs: 



syntax highlighted by Code2HTML, v. 0.9.1