# New ports collection makefile for: stream
# Date created: 10 May 2001
# Whom: Scott Flatman <sf@dsinw.com>
#
# $FreeBSD: ports/benchmarks/stream/Makefile,v 1.9 2007/05/26 15:14:19 araujo Exp $
PORTNAME= stream
PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= benchmarks
MASTER_SITES= http://www.cs.virginia.edu/stream/FTP/Code/
DISTFILES= stream.c
DIST_SUBDIR= stream-${PORTVERSION}
MAINTAINER= sf@slappy.org
COMMENT= Synthetic benchmark program that measures sustainable memory bandwidth
PLIST_FILES= bin/stream
PORTDOCS= stream.c
do-extract:
@${MKDIR} ${BUILD_WRKSRC}
@${CP} ${_DISTDIR}/stream.c ${BUILD_WRKSRC}
do-build:
(cd ${BUILD_WRKSRC} ; ${CC} ${CFLAGS} -o stream stream.c -lm)
do-install:
(cd ${BUILD_WRKSRC}; ${INSTALL_PROGRAM} stream ${PREFIX}/bin)
. if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
(cd ${_DISTDIR}; ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR})
. endif
.include <bsd.port.mk>
syntax highlighted by Code2HTML, v. 0.9.1