# New ports collection makefile for: 	fhist
# Date created:				Jan 05 2000
# Whom: 				<jkoshy@freebsd.org>
#
# $FreeBSD: ports/devel/fhist/Makefile,v 1.11 2006/01/07 04:44:46 jkoshy Exp $
#

PORTNAME=	fhist
PORTVERSION=	1.16
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=	${PORTNAME}

MAINTAINER=	jkoshy@freebsd.org
COMMENT=	Utilities to maintain file history, do file comparisions and merges

.include <bsd.port.pre.mk>

MAN1=		fcomp.1 fhist.1 fmerge.1
ALL_TARGET=	binaries
INSTALL_TARGET=	install-bin

GNU_CONFIGURE=	yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include

post-extract:
	cd ${WRKSRC}/lib/en/man1 && ${LN} -s ${WRKSRC}/etc/*.so .

post-install:
.for file in fhist fcomp fmerge
	${STRIP_CMD} ${PREFIX}/bin/${file}
	(cd ${WRKSRC}/lib/en/man1; soelim ${file}.1 > tmp; \
	${INSTALL_MAN} tmp ${PREFIX}/man/man1/${file}.1)
.endfor

.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1