# Makefile for utilities
# David Corcoran <corcoran@linuxnet.com>

INCLUDE = -I${PREFIX}/include -I${PREFIX}/include/PCSC
OBJS = testIBM.o testAMMI.o testSCHL.o testSIEMENS.o testBULL.o testGD.o commands.o testA.o testB.o


all: ifdtest 

clean:
	rm -f  ifdtest  *.o
ifdtest : ifdtest.c $(OBJS) commands.h
	$(CC) $(CFLAGS)  -o ifdtest ${OBJS} ifdtest.c $(INCLUDE) ${LIBS} 
%.o : %.c commands.h
	$(CC) $(CFLAGS) -c $< $(INCLUDE) 


syntax highlighted by Code2HTML, v. 0.9.1