# New ports collection makefile for:	k8048
# Date Created:		Oct 6 2007
# Whom:			Bruce M. Simpson <bms@FreeBSD.org>
#
# $FreeBSD: ports/devel/k8048/Makefile,v 1.3 2007/10/08 12:01:03 bms Exp $
#

PORTNAME=	k8048
PORTVERSION=	0.1
PORTREVISION=	2
CATEGORIES=	devel
MASTER_SITES=	http://dev.kewl.org/k8048/
DISTNAME=	$(PORTNAME)

MAINTAINER=	bms@FreeBSD.org
COMMENT=	Programs Microchip PICs using Velleman K8048 board

USE_GMAKE=	yes

#BUILD_DEPENDS+=	gpasm:${PORTSDIR}/devel/gputils

BIN_SYMLINKS=	bin/ktest bin/kdebug bin/k14 bin/k16
PLIST_FILES=	bin/${PORTNAME} ${BIN_SYMLINKS}

do-build:
	cd ${BUILD_WRKSRC}/${PORTNAME} && ${GMAKE} all

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}/${PORTNAME} \
			   ${PREFIX}/bin/${PORTNAME}

post-install:
.for i in ${BIN_SYMLINKS}
	cd ${PREFIX} && ${LN} -s ${PORTNAME} ${i}
.endfor

.include <bsd.port.mk>