# Makefile.in generated by automake 1.9.6 from Makefile.am.
# Makefile. Generated from Makefile.in by configure.
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
# 2003, 2004, 2005 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
# PARTICULAR PURPOSE.
# Makefile.am -- Makefile for the m17n database
# Copyright (C) 2003, 2004, 2005, 2006, 2007
# National Institute of Advanced Industrial Science and Technology (AIST)
# Registration Number H15PRO112
# This file is part of the m17n database; a sub-part of the m17n
# library.
# The m17n library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Lesser General Public License
# as published by the Free Software Foundation; either version 2.1 of
# the License, or (at your option) any later version.
# The m17n library is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# Lesser General Public License for more details.
# You should have received a copy of the GNU Lesser General Public
# License along with the m17n library; if not, write to the Free
# Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
# Boston, MA 02110-1301, USA.
srcdir = .
top_srcdir = .
pkglibdir = $(libdir)/m17n-db
pkgincludedir = $(includedir)/m17n-db
top_builddir = .
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
INSTALL = /usr/local/bin/ginstall -c
install_sh_DATA = $(install_sh) -c -m 644
install_sh_PROGRAM = $(install_sh) -c
install_sh_SCRIPT = $(install_sh) -c
INSTALL_HEADER = $(INSTALL_DATA)
transform = $(program_transform_name)
NORMAL_INSTALL = :
PRE_INSTALL = :
POST_INSTALL = :
NORMAL_UNINSTALL = :
PRE_UNINSTALL = :
POST_UNINSTALL = :
build_triplet = i386-unknown-gnu
host_triplet = i386-unknown-gnu
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
$(srcdir)/Makefile.in $(srcdir)/m17n-db.in \
$(srcdir)/m17n-db.pc.in $(srcdir)/mapconv.in \
$(top_srcdir)/configure ABOUT-NLS AUTHORS COPYING ChangeLog \
INSTALL NEWS config.guess config.rpath config.sub install-sh \
missing mkinstalldirs
subdir = .
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/gettext.m4 \
$(top_srcdir)/m4/iconv.m4 $(top_srcdir)/m4/lib-ld.m4 \
$(top_srcdir)/m4/lib-link.m4 $(top_srcdir)/m4/lib-prefix.m4 \
$(top_srcdir)/m4/nls.m4 $(top_srcdir)/m4/po.m4 \
$(top_srcdir)/m4/progtest.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
configure.lineno configure.status.lineno
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_CLEAN_FILES = mapconv m17n-db m17n-db.pc
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgconfigdir)" \
"$(DESTDIR)$(pkgdatadir)"
binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
SCRIPTS = $(bin_SCRIPTS)
SOURCES =
DIST_SOURCES =
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
html-recursive info-recursive install-data-recursive \
install-exec-recursive install-info-recursive \
install-recursive installcheck-recursive installdirs-recursive \
pdf-recursive ps-recursive uninstall-info-recursive \
uninstall-recursive
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
*) f=$$p;; \
esac;
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
pkgconfigDATA_INSTALL = $(INSTALL_DATA)
pkgdataDATA_INSTALL = $(INSTALL_DATA)
DATA = $(pkgconfig_DATA) $(pkgdata_DATA)
ETAGS = etags
CTAGS = ctags
DIST_SUBDIRS = $(SUBDIRS)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
am__remove_distdir = \
{ test ! -d $(distdir) \
|| { find $(distdir) -type d ! -perm -200 -exec chmod u+w {} ';' \
&& rm -fr $(distdir); }; }
DIST_ARCHIVES = $(distdir).tar.gz
GZIP_ENV = --best
distuninstallcheck_listfiles = find . -type f -print
distcleancheck_listfiles = find . -type f -print
pkgdatadir = $(datadir)/m17n
ACLOCAL = ${SHELL} /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/missing --run aclocal-1.9
AMDEP_FALSE = #
AMDEP_TRUE =
AMTAR = ${SHELL} /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/missing --run tar
AUTOCONF = ${SHELL} /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/missing --run autoconf
AUTOHEADER = ${SHELL} /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/missing --run autoheader
AUTOMAKE = ${SHELL} /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/missing --run automake-1.9
AWK = gawk
CC = gcc
CCDEPMODE = depmode=none
CFLAGS = -fno-common
# Rules for charsets
CHARMAPS =
CHARMAP_CAT =
CHARMAP_EXT =
CPPFLAGS =
CYGPATH_W = echo
DEFS = -DPACKAGE_NAME=\"m17n-db\" -DPACKAGE_TARNAME=\"m17n-db\" -DPACKAGE_VERSION=\"1.4.0\" -DPACKAGE_STRING=\"m17n-db\ 1.4.0\" -DPACKAGE_BUGREPORT=\"bugs-m17n-lib@m17n.org\" -DPACKAGE=\"m17n-db\" -DVERSION=\"1.4.0\" -DHAVE_CFPREFERENCESCOPYAPPVALUE=1
DEPDIR = .deps
ECHO_C =
ECHO_N = -n
ECHO_T =
EXEEXT =
GMSGFMT = /usr/local/bin/msgfmt
GMSGFMT_015 = :
ICONS = am-sera.png ar-kbd.png as-itrans.png bn-itrans.png bn-unijoy.png bo-wylie.png bopo-kbd.png dv-phonetic.png el-kbd.png en-ispell.png fa-isiri.png gu-itrans.png he-kbd.png hi-itrans.png hr-kbd.png hy-kbd.png ja-anthy.png ja-tcode.png ka-kbd.png kk-arabic.png kk-kbd.png km-yannis.png kn-itrans.png ko-han2.png ko-romaja.png latn-post.png latn-pre.png lo-kbd.png lo-lrt.png ml-itrans.png my-kbd.png or-itrans.png pa-itrans.png rfc1345.png ru-kbd.png ru-yawerty.png si-samanala.png si-wijesekera.png sk-kbd.png sr-kbd.png sv-post.png syrc-phonetic.png ta-itrans.png te-itrans.png th-kesmanee-2.png th-kesmanee.png th-pattachote-2.png th-pattachote.png th-tis820-2.png th-tis820.png unicode.png vi-telex.png vi-viqr.png vi-vni.png zh-cangjie.png zh-pinyin.png zh-py-b5.png zh-py-gb.png zh-py.png zh-quick.png zh-tonepy-b5.png zh-tonepy-gb.png zh-tonepy.png
INSTALL_DATA = ${INSTALL} -m 644
INSTALL_PROGRAM = ${INSTALL}
INSTALL_SCRIPT = ${INSTALL}
INSTALL_STRIP_PROGRAM = ${SHELL} $(install_sh) -c -s
INTLLIBS =
INTL_MACOSX_LIBS = -Wl,-framework -Wl,CoreFoundation
LANGNAME_TABLES = aa.lnm af.lnm am.lnm ar.lnm as.lnm az.lnm az_Cyrl.lnm az_Latn.lnm be.lnm bg.lnm bn.lnm bs.lnm byn.lnm ca.lnm cs.lnm cy.lnm da.lnm de.lnm dv.lnm dz.lnm el.lnm en.lnm eo.lnm es.lnm et.lnm eu.lnm fa.lnm fi.lnm fo.lnm fr.lnm fur.lnm ga.lnm gez.lnm gl.lnm gu.lnm gv.lnm haw.lnm he.lnm hi.lnm hr.lnm hu.lnm hy.lnm id.lnm is.lnm it.lnm iu.lnm ja.lnm ka.lnm kk.lnm kl.lnm km.lnm kn.lnm ko.lnm kok.lnm ku.lnm kw.lnm ky.lnm ln.lnm lo.lnm lt.lnm lv.lnm mk.lnm ml.lnm mn.lnm mr.lnm ms.lnm mt.lnm nb.lnm nl.lnm nn.lnm om.lnm or.lnm pa.lnm pl.lnm ps.lnm pt.lnm ro.lnm ru.lnm sa.lnm se.lnm sid.lnm sk.lnm sl.lnm so.lnm sq.lnm sr.lnm sr_Latn.lnm sv.lnm sw.lnm syr.lnm ta.lnm te.lnm tg.lnm th.lnm ti.lnm tig.lnm tr.lnm tt.lnm uk.lnm ur.lnm uz.lnm uz_Arab.lnm uz_Latn.lnm vi.lnm wal.lnm zh.lnm zh_Hans.lnm zh_Hant.lnm
LDFLAGS =
LIBICONV =
LIBINTL =
LIBOBJS =
LIBS =
LTLIBICONV =
LTLIBINTL =
LTLIBOBJS =
MAKEINFO = ${SHELL} /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/missing --run makeinfo
MSGFMT = /usr/local/bin/msgfmt
MSGFMT_015 = :
MSGMERGE = /usr/local/bin/msgmerge
OBJEXT =
PACKAGE = m17n-db
PACKAGE_BUGREPORT = bugs-m17n-lib@m17n.org
PACKAGE_NAME = m17n-db
PACKAGE_STRING = m17n-db 1.4.0
PACKAGE_TARNAME = m17n-db
PACKAGE_VERSION = 1.4.0
PATH_SEPARATOR = :
POSUB =
SET_MAKE =
SHELL = /bin/sh
STRIP =
USE_NLS = no
VERSION = 1.4.0
XGETTEXT = /usr/local/bin/xgettext
XGETTEXT_015 = :
ac_ct_CC = gcc
am__fastdepCC_FALSE =
am__fastdepCC_TRUE = #
am__include = include
am__leading_dot = .
am__quote =
am__tar = ${AMTAR} chof - "$$tardir"
am__untar = ${AMTAR} xf -
bindir = ${exec_prefix}/bin
build = i386-unknown-gnu
build_alias = i386-unknown-gnu
build_cpu = i386
build_os = gnu
build_vendor = unknown
datadir = ${datarootdir}
datarootdir = ${prefix}/share
docdir = ${datarootdir}/doc/${PACKAGE_TARNAME}
dvidir = ${docdir}
exec_prefix = ${prefix}
host = i386-unknown-gnu
host_alias = i386-unknown-gnu
host_cpu = i386
host_os = gnu
host_vendor = unknown
htmldir = ${docdir}
includedir = ${prefix}/include
infodir = ${datarootdir}/info
install_sh = /mnt/gmirror/ports/devel/m17n-db/work/m17n-db-1.4.0/install-sh
libdir = ${exec_prefix}/lib
libexecdir = ${exec_prefix}/libexec
localedir = ${datarootdir}/locale
localstatedir = ${prefix}/var
mandir = ${datarootdir}/man
mkdir_p = mkdir -p --
oldincludedir = /usr/include
pdfdir = ${docdir}
prefix =
program_transform_name = s,x,x,
psdir = ${docdir}
sbindir = ${exec_prefix}/sbin
sharedstatedir = ${prefix}/com
sysconfdir = ${prefix}/etc
target_alias = i386-unknown-gnu
SUBDIRS = po icons FLT MIM LANGDATA
pkgdata_DATA = \
${CHARSETS} \
${CHAR_TABLE} \
${MISC_TABLE} \
mdb.dir
EXTRA_DIST = config.rpath mkinstalldirs m4/ChangeLog \
mdb.dir \
${MISC_TABLE} \
BLOCK.tab \
${UNIDATA} \
mapconv compact.awk gb180302.awk gb180304.awk \
CHARTAB.awk NAME.awk LINEBREAK.awk \
CASED.awk CASE-MAPPING.awk \
SCRIPT.awk SCRIPT.ext \
get-glibc.sh \
${FORMATS}
CHARSETS = ${ISO8859} ${IBM} ${CODEPAGE} ${CJK} ${MISC}
ISO8859 = \
8859-2.map 8859-3.map 8859-4.map 8859-5.map 8859-6.map 8859-7.map \
8859-8.map 8859-9.map 8859-10.map 8859-11.map 8859-13.map 8859-14.map \
8859-15.map 8859-16.map
IBM = \
IBM037.map IBM038.map \
IBM256.map IBM273.map IBM274.map IBM275.map IBM277.map IBM278.map \
IBM280.map IBM281.map IBM284.map IBM285.map IBM290.map IBM297.map \
IBM420.map IBM423.map IBM424.map IBM437.map IBM500.map IBM850.map \
IBM851.map IBM852.map IBM855.map IBM857.map IBM860.map IBM861.map \
IBM862.map IBM863.map IBM864.map IBM865.map IBM866.map IBM868.map \
IBM869.map IBM870.map IBM871.map IBM874.map IBM875.map IBM880.map \
IBM891.map IBM903.map IBM904.map IBM905.map IBM918.map \
IBM1004.map IBM1026.map IBM1047.map
CODEPAGE = \
CP737.map CP775.map CP949-2BYTE.map \
CP1250.map CP1251.map CP1252.map CP1253.map CP1254.map \
CP1255.map CP1256.map CP1257.map CP1258.map \
CP10007.map
CJK = GB_1988-80.map GB2312.map GBK.map GB180302.map GB180304.map \
BIG5.map BIG5-HKSCS.map\
CNS-1.map CNS-2.map CNS-3.map CNS-4.map CNS-5.map CNS-6.map CNS-7.map \
CNS-F.map \
JISX0201.map JISX0208.map JISX0212.map JISX2131.map JISX2132.map \
JISX213A.map \
KSC5601.map KSC5636.map JOHAB.map
MISC = KOI-8.map KOI8-R.map KOI8-U.map KOI8-T.map \
TIS-620.map VISCII.map VSCII.map\
KA-PS.map KA-ACADEMY.map
CHAR_TABLE = \
NAME.tab SCRIPT.tab CASE-S.tab CASE-C.tab \
CATEGORY.tab COMBINE.tab BIDI.tab LINEBREAK.tab \
CASED.tab SOFT-DOTTED.tab CASE-MAPPING.tab \
BLOCK.tab
MISC_TABLE = \
LOCALE.cs LOCALE.ali \
default.fst xfont.fst truetype.fst generic.fst \
FONTENC.tbl FONTSIZE.tbl \
CHARSET.tbl CODING.tbl \
SCRIPT.tbl SCRIPT-OTF.tbl SCRIPT-LANGUAGE.tbl
UNIDATA = \
UNIDATA/README \
UNIDATA/UnicodeData.txt UNIDATA/Scripts.txt UNIDATA/CaseFolding.txt \
UNIDATA/LineBreak.txt \
UNIDATA/PropList.txt UNIDATA/WordBreakProperty.txt \
UNIDATA/SpecialCasing.txt
FORMATS = \
FORMATS/README \
FORMATS/0General.txt FORMATS/CharsetList.txt FORMATS/CodingList.txt \
FORMATS/Dir.txt FORMATS/FontEncoding.txt FORMATS/Fontset.txt \
FORMATS/FLT.txt FORMATS/FontSize.txt FORMATS/IM.txt
bin_SCRIPTS = m17n-db
pkgconfigdir = ${prefix}/libdata/pkgconfig
pkgconfig_DATA = m17n-db.pc
ACLOCAL_AMFLAGS = -I m4
all: all-recursive
.SUFFIXES:
am--refresh:
@:
$(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(am__configure_deps)
@for dep in $?; do \
case '$(am__configure_deps)' in \
*$$dep*) \
echo ' cd $(srcdir) && $(AUTOMAKE) --gnu '; \
cd $(srcdir) && $(AUTOMAKE) --gnu \
&& exit 0; \
exit 1;; \
esac; \
done; \
echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu Makefile'; \
cd $(top_srcdir) && \
$(AUTOMAKE) --gnu Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
@case '$?' in \
*config.status*) \
echo ' $(SHELL) ./config.status'; \
$(SHELL) ./config.status;; \
*) \
echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)'; \
cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe);; \
esac;
$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
$(SHELL) ./config.status --recheck
$(top_srcdir)/configure: $(am__configure_deps)
cd $(srcdir) && $(AUTOCONF)
$(ACLOCAL_M4): $(am__aclocal_m4_deps)
cd $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
mapconv: $(top_builddir)/config.status $(srcdir)/mapconv.in
cd $(top_builddir) && $(SHELL) ./config.status $@
m17n-db: $(top_builddir)/config.status $(srcdir)/m17n-db.in
cd $(top_builddir) && $(SHELL) ./config.status $@
m17n-db.pc: $(top_builddir)/config.status $(srcdir)/m17n-db.pc.in
cd $(top_builddir) && $(SHELL) ./config.status $@
install-binSCRIPTS: $(bin_SCRIPTS)
@$(NORMAL_INSTALL)
test -z "$(bindir)" || $(mkdir_p) "$(DESTDIR)$(bindir)"
@list='$(bin_SCRIPTS)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
if test -f $$d$$p; then \
f=`echo "$$p" | sed 's|^.*/||;$(transform)'`; \
echo " $(binSCRIPT_INSTALL) '$$d$$p' '$(DESTDIR)$(bindir)/$$f'"; \
$(binSCRIPT_INSTALL) "$$d$$p" "$(DESTDIR)$(bindir)/$$f"; \
else :; fi; \
done
uninstall-binSCRIPTS:
@$(NORMAL_UNINSTALL)
@list='$(bin_SCRIPTS)'; for p in $$list; do \
f=`echo "$$p" | sed 's|^.*/||;$(transform)'`; \
echo " rm -f '$(DESTDIR)$(bindir)/$$f'"; \
rm -f "$(DESTDIR)$(bindir)/$$f"; \
done
uninstall-info-am:
install-pkgconfigDATA: $(pkgconfig_DATA)
@$(NORMAL_INSTALL)
test -z "$(pkgconfigdir)" || $(mkdir_p) "$(DESTDIR)$(pkgconfigdir)"
@list='$(pkgconfig_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
f=$(am__strip_dir) \
echo " $(pkgconfigDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgconfigdir)/$$f'"; \
$(pkgconfigDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgconfigdir)/$$f"; \
done
uninstall-pkgconfigDATA:
@$(NORMAL_UNINSTALL)
@list='$(pkgconfig_DATA)'; for p in $$list; do \
f=$(am__strip_dir) \
echo " rm -f '$(DESTDIR)$(pkgconfigdir)/$$f'"; \
rm -f "$(DESTDIR)$(pkgconfigdir)/$$f"; \
done
install-pkgdataDATA: $(pkgdata_DATA)
@$(NORMAL_INSTALL)
test -z "$(pkgdatadir)" || $(mkdir_p) "$(DESTDIR)$(pkgdatadir)"
@list='$(pkgdata_DATA)'; for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
f=$(am__strip_dir) \
echo " $(pkgdataDATA_INSTALL) '$$d$$p' '$(DESTDIR)$(pkgdatadir)/$$f'"; \
$(pkgdataDATA_INSTALL) "$$d$$p" "$(DESTDIR)$(pkgdatadir)/$$f"; \
done
uninstall-pkgdataDATA:
@$(NORMAL_UNINSTALL)
@list='$(pkgdata_DATA)'; for p in $$list; do \
f=$(am__strip_dir) \
echo " rm -f '$(DESTDIR)$(pkgdatadir)/$$f'"; \
rm -f "$(DESTDIR)$(pkgdatadir)/$$f"; \
done
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
# To change the values of `make' variables: instead of editing Makefiles,
# (1) if the variable is set in `config.status', edit `config.status'
# (which will cause the Makefiles to be regenerated when you run `make');
# (2) otherwise, pass the desired values on the `make' command line.
$(RECURSIVE_TARGETS):
@failcom='exit 1'; \
for f in x $$MAKEFLAGS; do \
case $$f in \
*=* | --[!k]*);; \
*k*) failcom='fail=yes';; \
esac; \
done; \
dot_seen=no; \
target=`echo $@ | sed s/-recursive//`; \
list='$(SUBDIRS)'; for subdir in $$list; do \
echo "Making $$target in $$subdir"; \
if test "$$subdir" = "."; then \
dot_seen=yes; \
local_target="$$target-am"; \
else \
local_target="$$target"; \
fi; \
(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
|| eval $$failcom; \
done; \
if test "$$dot_seen" = "no"; then \
$(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
fi; test -z "$$fail"
mostlyclean-recursive clean-recursive distclean-recursive \
maintainer-clean-recursive:
@failcom='exit 1'; \
for f in x $$MAKEFLAGS; do \
case $$f in \
*=* | --[!k]*);; \
*k*) failcom='fail=yes';; \
esac; \
done; \
dot_seen=no; \
case "$@" in \
distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
*) list='$(SUBDIRS)' ;; \
esac; \
rev=''; for subdir in $$list; do \
if test "$$subdir" = "."; then :; else \
rev="$$subdir $$rev"; \
fi; \
done; \
rev="$$rev ."; \
target=`echo $@ | sed s/-recursive//`; \
for subdir in $$rev; do \
echo "Making $$target in $$subdir"; \
if test "$$subdir" = "."; then \
local_target="$$target-am"; \
else \
local_target="$$target"; \
fi; \
(cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
|| eval $$failcom; \
done && test -z "$$fail"
tags-recursive:
list='$(SUBDIRS)'; for subdir in $$list; do \
test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
done
ctags-recursive:
list='$(SUBDIRS)'; for subdir in $$list; do \
test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
done
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
$(AWK) ' { files[$$0] = 1; } \
END { for (i in files) print i; }'`; \
mkid -fID $$unique
tags: TAGS
TAGS: tags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
tags=; \
here=`pwd`; \
if ($(ETAGS) --etags-include --version) >/dev/null 2>&1; then \
include_option=--etags-include; \
empty_fix=.; \
else \
include_option=--include; \
empty_fix=; \
fi; \
list='$(SUBDIRS)'; for subdir in $$list; do \
if test "$$subdir" = .; then :; else \
test ! -f $$subdir/TAGS || \
tags="$$tags $$include_option=$$here/$$subdir/TAGS"; \
fi; \
done; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
$(AWK) ' { files[$$0] = 1; } \
END { for (i in files) print i; }'`; \
if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
test -n "$$unique" || unique=$$empty_fix; \
$(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
$$tags $$unique; \
fi
ctags: CTAGS
CTAGS: ctags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
tags=; \
here=`pwd`; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
$(AWK) ' { files[$$0] = 1; } \
END { for (i in files) print i; }'`; \
test -z "$(CTAGS_ARGS)$$tags$$unique" \
|| $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
$$tags $$unique
GTAGS:
here=`$(am__cd) $(top_builddir) && pwd` \
&& cd $(top_srcdir) \
&& gtags -i $(GTAGS_ARGS) $$here
distclean-tags:
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
distdir: $(DISTFILES)
$(am__remove_distdir)
mkdir $(distdir)
$(mkdir_p) $(distdir)/. $(distdir)/FORMATS $(distdir)/UNIDATA $(distdir)/m4 $(distdir)/po
@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
list='$(DISTFILES)'; for file in $$list; do \
case $$file in \
$(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
$(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
esac; \
if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
if test "$$dir" != "$$file" && test "$$dir" != "."; then \
dir="/$$dir"; \
$(mkdir_p) "$(distdir)$$dir"; \
else \
dir=''; \
fi; \
if test -d $$d/$$file; then \
if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
fi; \
cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
else \
test -f $(distdir)/$$file \
|| cp -p $$d/$$file $(distdir)/$$file \
|| exit 1; \
fi; \
done
list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
if test "$$subdir" = .; then :; else \
test -d "$(distdir)/$$subdir" \
|| $(mkdir_p) "$(distdir)/$$subdir" \
|| exit 1; \
distdir=`$(am__cd) $(distdir) && pwd`; \
top_distdir=`$(am__cd) $(top_distdir) && pwd`; \
(cd $$subdir && \
$(MAKE) $(AM_MAKEFLAGS) \
top_distdir="$$top_distdir" \
distdir="$$distdir/$$subdir" \
distdir) \
|| exit 1; \
fi; \
done
-find $(distdir) -type d ! -perm -777 -exec chmod a+rwx {} \; -o \
! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \
! -type d ! -perm -400 -exec chmod a+r {} \; -o \
! -type d ! -perm -444 -exec $(SHELL) $(install_sh) -c -m a+r {} {} \; \
|| chmod -R a+r $(distdir)
dist-gzip: distdir
tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
$(am__remove_distdir)
dist-bzip2: distdir
tardir=$(distdir) && $(am__tar) | bzip2 -9 -c >$(distdir).tar.bz2
$(am__remove_distdir)
dist-tarZ: distdir
tardir=$(distdir) && $(am__tar) | compress -c >$(distdir).tar.Z
$(am__remove_distdir)
dist-shar: distdir
shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
$(am__remove_distdir)
dist-zip: distdir
-rm -f $(distdir).zip
zip -rq $(distdir).zip $(distdir)
$(am__remove_distdir)
dist dist-all: distdir
tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
$(am__remove_distdir)
# This target untars the dist file and tries a VPATH configuration. Then
# it guarantees that the distribution is self-contained by making another
# tarfile.
distcheck: dist
case '$(DIST_ARCHIVES)' in \
*.tar.gz*) \
GZIP=$(GZIP_ENV) gunzip -c $(distdir).tar.gz | $(am__untar) ;;\
*.tar.bz2*) \
bunzip2 -c $(distdir).tar.bz2 | $(am__untar) ;;\
*.tar.Z*) \
uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
*.shar.gz*) \
GZIP=$(GZIP_ENV) gunzip -c $(distdir).shar.gz | unshar ;;\
*.zip*) \
unzip $(distdir).zip ;;\
esac
chmod -R a-w $(distdir); chmod a+w $(distdir)
mkdir $(distdir)/_build
mkdir $(distdir)/_inst
chmod a-w $(distdir)
dc_install_base=`$(am__cd) $(distdir)/_inst && pwd | sed -e 's,^[^:\\/]:[\\/],/,'` \
&& dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
&& cd $(distdir)/_build \
&& ../configure --srcdir=.. --prefix="$$dc_install_base" \
$(DISTCHECK_CONFIGURE_FLAGS) \
&& $(MAKE) $(AM_MAKEFLAGS) \
&& $(MAKE) $(AM_MAKEFLAGS) dvi \
&& $(MAKE) $(AM_MAKEFLAGS) check \
&& $(MAKE) $(AM_MAKEFLAGS) install \
&& $(MAKE) $(AM_MAKEFLAGS) installcheck \
&& $(MAKE) $(AM_MAKEFLAGS) uninstall \
&& $(MAKE) $(AM_MAKEFLAGS) distuninstallcheck_dir="$$dc_install_base" \
distuninstallcheck \
&& chmod -R a-w "$$dc_install_base" \
&& ({ \
(cd ../.. && umask 077 && mkdir "$$dc_destdir") \
&& $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" install \
&& $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" uninstall \
&& $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" \
distuninstallcheck_dir="$$dc_destdir" distuninstallcheck; \
} || { rm -rf "$$dc_destdir"; exit 1; }) \
&& rm -rf "$$dc_destdir" \
&& $(MAKE) $(AM_MAKEFLAGS) dist \
&& rm -rf $(DIST_ARCHIVES) \
&& $(MAKE) $(AM_MAKEFLAGS) distcleancheck
$(am__remove_distdir)
@(echo "$(distdir) archives ready for distribution: "; \
list='$(DIST_ARCHIVES)'; for i in $$list; do echo $$i; done) | \
sed -e '1{h;s/./=/g;p;x;}' -e '$${p;x;}'
distuninstallcheck:
@cd $(distuninstallcheck_dir) \
&& test `$(distuninstallcheck_listfiles) | wc -l` -le 1 \
|| { echo "ERROR: files left after uninstall:" ; \
if test -n "$(DESTDIR)"; then \
echo " (check DESTDIR support)"; \
fi ; \
$(distuninstallcheck_listfiles) ; \
exit 1; } >&2
distcleancheck: distclean
@if test '$(srcdir)' = . ; then \
echo "ERROR: distcleancheck can only run from a VPATH build" ; \
exit 1 ; \
fi
@test `$(distcleancheck_listfiles) | wc -l` -eq 0 \
|| { echo "ERROR: files left in build directory after distclean:" ; \
$(distcleancheck_listfiles) ; \
exit 1; } >&2
check-am: all-am
check: check-recursive
all-am: Makefile $(SCRIPTS) $(DATA)
installdirs: installdirs-recursive
installdirs-am:
for dir in "$(DESTDIR)$(bindir)" "$(DESTDIR)$(pkgconfigdir)" "$(DESTDIR)$(pkgdatadir)"; do \
test -z "$$dir" || $(mkdir_p) "$$dir"; \
done
install: install-recursive
install-exec: install-exec-recursive
install-data: install-data-recursive
uninstall: uninstall-recursive
install-am: all-am
@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
installcheck: installcheck-recursive
install-strip:
$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
`test -z '$(STRIP)' || \
echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
mostlyclean-generic:
clean-generic:
distclean-generic:
-test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@echo "it deletes files that may require special tools to rebuild."
clean-am: clean-generic mostlyclean-am
distclean: distclean-recursive
-rm -f $(am__CONFIG_DISTCLEAN_FILES)
-rm -f Makefile
distclean-am: clean-am distclean-generic distclean-tags
dvi: dvi-recursive
dvi-am:
html: html-recursive
info: info-recursive
info-am:
install-data-am: install-pkgconfigDATA install-pkgdataDATA
install-exec-am: install-binSCRIPTS
install-info: install-info-recursive
install-man:
installcheck-am:
maintainer-clean: maintainer-clean-recursive
-rm -f $(am__CONFIG_DISTCLEAN_FILES)
-rm -rf $(top_srcdir)/autom4te.cache
-rm -f Makefile
maintainer-clean-am: distclean-am maintainer-clean-generic
mostlyclean: mostlyclean-recursive
mostlyclean-am: mostlyclean-generic
pdf: pdf-recursive
pdf-am:
ps: ps-recursive
ps-am:
uninstall-am: uninstall-binSCRIPTS uninstall-info-am \
uninstall-pkgconfigDATA uninstall-pkgdataDATA
uninstall-info: uninstall-info-recursive
.PHONY: $(RECURSIVE_TARGETS) CTAGS GTAGS all all-am am--refresh check \
check-am clean clean-generic clean-recursive ctags \
ctags-recursive dist dist-all dist-bzip2 dist-gzip dist-shar \
dist-tarZ dist-zip distcheck distclean distclean-generic \
distclean-recursive distclean-tags distcleancheck distdir \
distuninstallcheck dvi dvi-am html html-am info info-am \
install install-am install-binSCRIPTS install-data \
install-data-am install-exec install-exec-am install-info \
install-info-am install-man install-pkgconfigDATA \
install-pkgdataDATA install-strip installcheck installcheck-am \
installdirs installdirs-am maintainer-clean \
maintainer-clean-generic maintainer-clean-recursive \
mostlyclean mostlyclean-generic mostlyclean-recursive pdf \
pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
uninstall-binSCRIPTS uninstall-info-am uninstall-pkgconfigDATA \
uninstall-pkgdataDATA
GB2312.map: ${CHARMAPS}/GB2312${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[a-f]/' 2 NOMSB compact > $@
GBK.map: ${CHARMAPS}/GBK${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[89a-f]/' 2 WITHMSB compact > $@
GB180302.map: ${CHARMAPS}/GB18030${CHARMAP_EXT} mapconv gb180302.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x..\/x..[ ]/' 2 WITHMSB gb180302 > $@
GB180304.map: GB180302.map gb180304.awk
@echo "Generating $@..."
@$(AWK) -f gb180304.awk < $< > $@
JISX0201.map: ${CHARMAPS}/JIS_X0201${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[0-9]/' 1 WITHMSB compact > $@
@echo "# Generated by hand" >> $@
@echo "0x00A1-0x00DF 0xFF61" >> $@
JISX0208.map: ${CHARMAPS}/EUC-JP${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[a-f]/' 2 NOMSB compact \
| sed 's/0x2015/0x2014/' > $@> $@
JISX0212.map: ${CHARMAPS}/EUC-JP${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x8f/ s,/x8f,,' 2 NOMSB compact > $@
JISX2131.map: ${CHARMAPS}/EUC-JISX0213${CHARMAP_EXT} mapconv
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[a-f]/' 2 NOMSB \
| sed 's/0x2015/0x2014/' > $@> $@
JISX2132.map: ${CHARMAPS}/EUC-JISX0213${CHARMAP_EXT} mapconv
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x8f/ s,/x8f,,' 2 NOMSB > $@
JISX213A.map:
@echo "Generating $@"
@(echo "0x2E21 0x4FF1"; \
echo "0x2F7E 0x525D"; \
echo "0x4F54 0x20B9F"; \
echo "0x4F7E 0x541E"; \
echo "0x7427 0x5653"; \
echo "0x7E7A 0x59F8"; \
echo "0x7E7B 0x5C5B"; \
echo "0x7E7C 0x5E77"; \
echo "0x7E7D 0x7626"; \
echo "0x7E7E 0x7E6B") > $@
KSC5601.map: ${CHARMAPS}/EUC-KR${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[a-f]/' 2 NOMSB compact > $@
BIG5.map: ${CHARMAPS}/BIG5${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[a-f]/' 2 WITHMSB compact > $@
BIG5-HKSCS.map: ${CHARMAPS}/BIG5-HKSCS${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[89a-f].\//' 2 WITHMSB compact > $@
JOHAB.map: ${CHARMAPS}/JOHAB${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[89a-f]/' 2 WITHMSB compact > $@
CNS-1.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[a-f]/' 2 NOMSB compact > $@
CNS-2.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xa2/ s,/x8e/xa2,,' 2 NOMSB compact > $@
CNS-3.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xa3/ s,/x8e/xa3,,' 2 NOMSB compact > $@
CNS-4.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xa4/ s,/x8e/xa4,,' 2 NOMSB compact > $@
CNS-5.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xa5/ s,/x8e/xa5,,' 2 NOMSB compact > $@
CNS-6.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xa6/ s,/x8e/xa6,,' 2 NOMSB compact > $@
CNS-7.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xa7/ s,/x8e/xa7,,' 2 NOMSB compact > $@
CNS-F.map: ${CHARMAPS}/EUC-TW${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*\/x8e\/xaf/ s,/x8e/xaf,,' 2 NOMSB compact > $@
CP949-2BYTE.map: ${CHARMAPS}/CP949${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[89a-f]/' 2 WITHMSB compact > $@
VSCII.map: ${CHARMAPS}/TCVN5712-1${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x[0-9a-f]. /' 1 WITHMSB compact > $@
# General target to produce map files for single-byte charsets.
8859-%.map: ${CHARMAPS}/ISO-8859-%${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x/' 1 WITHMSB compact > $@
KA-%.map: ${CHARMAPS}/GEORGIAN-%${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x/' 1 WITHMSB compact > $@
%.map: ${CHARMAPS}/%${CHARMAP_EXT} mapconv compact.awk
@echo "Generating $@..."
@sh mapconv $< '/^<.*[ ]\/x/' 1 WITHMSB compact > $@
# Rules for chartables
CASE-S.tab: UNIDATA/CaseFolding.txt Makefile
echo "# Generated from $<." > $@
@$(AWK) '/^[0-9A-Z]/ { \
if ($$2 == "F") print "0x"$$1,"0xFFFF"; \
else print "0x"$$1,"0x"$$3; }' FS="[; ][; ]*" $< >> $@
CASE-C.tab: UNIDATA/CaseFolding.txt Makefile
echo "# Generated from $<." > $@
@$(AWK) '/^[0-9A-Z]*; F/ { \
print "0x"$$1" "; \
for (i = 3; $$i != "#"; i++) \
printf "\\x%s",$$i; \
print "\n"; }' FS="[; ][; ]*" ORS="" $< >> $@
NAME.tab: UNIDATA/UnicodeData.txt NAME.awk
echo "# Generated from $<." > $@
@$(AWK) -f NAME.awk $< >> $@
SCRIPT.tab: UNIDATA/Scripts.txt UNIDATA/UnicodeData.txt SCRIPT.awk SCRIPT.ext
echo "# Generated from $<." > $@
@$(AWK) -f SCRIPT.awk UNIDATA/Scripts.txt >> $@
CASED.tab: UNIDATA/UnicodeData.txt UNIDATA/PropList.txt UNIDATA/WordBreakProperty.txt CASED.awk
echo "# Generated from UNIDATA/UnicodeData.txt, UNIDATA/PropList.txt, and UNIDATA/WordBreakProperty.txt." > $@
@$(AWK) -f CASED.awk UNIDATA/UnicodeData.txt UNIDATA/PropList.txt UNIDATA/WordBreakProperty.txt >> $@
SOFT-DOTTED.tab: UNIDATA/PropList.txt Makefile
echo "# Generated from $<." > $@
@$(AWK) '/^[^#;]+; *Soft_Dotted/ { \
if (index ($$1, ".")) { \
split ($$1, A, "\\.\\."); \
print "0x"A[1]"-0x"A[2]" t"; } \
else print "0x"$$1" t"; }' \
$< >> $@
CASE-MAPPING.tab: UNIDATA/SpecialCasing.txt UNIDATA/UnicodeData.txt CASE-MAPPING.awk
echo "# Generated from UNIDATA/SpecialCasing.txt and UNIDATA/UnicodeData.txt." > $@
@$(AWK) -f CASE-MAPPING.awk UNIDATA/SpecialCasing.txt UNIDATA/UnicodeData.txt >> $@
LINEBREAK.tab: UNIDATA/LineBreak.txt LINEBREAK.awk
echo "# Generated from $<." > $@
@$(AWK) -f LINEBREAK.awk $< >> $@
BLOCK.tab:
echo "No need to re-generate BLOCK.tab."
%.tab: UNIDATA/UnicodeData.txt CHARTAB.awk
echo "# Generated from $<." > $@
@$(AWK) -f CHARTAB.awk FIELD=$@ $< >>$@
# Clear files that are automatically generated.
clean:
rm -f ${CHARSETS} ${CHAR_TABLE}
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:
syntax highlighted by Code2HTML, v. 0.9.1