# Makefile.in generated by automake 1.9.6 from Makefile.am.
# Makefile.  Generated from Makefile.in by configure.

# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
# 2003, 2004, 2005  Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.

# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
# PARTICULAR PURPOSE.



# Makefile.am -- Makefile for the m17n library documentation.
# Copyright (C) 2003, 2004, 2005, 2006
#   National Institute of Advanced Industrial Science and Technology (AIST)
#   Registration Number H15PRO112

# This file is part of the m17n library documentation, a sub-part of
# the m17n library.

# The m17n library is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
# published by the Free Software Foundation; either version 2, or (at
# your option) any later version.

# The m17n library is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.

# You should have received a copy of the GNU General Public License
# along with the m17n library; see the file COPYING.  If not, write to
# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
# Boston, MA 02111-1307, USA.

srcdir = .
top_srcdir = .

pkglibdir = $(libdir)/m17n-docs
pkgincludedir = $(includedir)/m17n-docs
top_builddir = .
am__cd = CDPATH="$${ZSH_VERSION+.}$(PATH_SEPARATOR)" && cd
INSTALL = /usr/bin/install -c -o root -g wheel
install_sh_DATA = $(install_sh) -c -m 644
install_sh_PROGRAM = $(install_sh) -c
install_sh_SCRIPT = $(install_sh) -c
INSTALL_HEADER = $(INSTALL_DATA)
transform = $(program_transform_name)
NORMAL_INSTALL = :
PRE_INSTALL = :
POST_INSTALL = :
NORMAL_UNINSTALL = :
PRE_UNINSTALL = :
POST_UNINSTALL = :
subdir = .
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
	$(srcdir)/Makefile.in $(top_srcdir)/configure AUTHORS COPYING \
	ChangeLog INSTALL NEWS depcomp install-sh missing
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
	$(ACLOCAL_M4)
am__CONFIG_DISTCLEAN_FILES = config.status config.cache config.log \
 configure.lineno configure.status.lineno
mkinstalldirs = $(install_sh) -d
CONFIG_CLEAN_FILES =
SOURCES =
DIST_SOURCES =
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
	html-recursive info-recursive install-data-recursive \
	install-exec-recursive install-info-recursive \
	install-recursive installcheck-recursive installdirs-recursive \
	pdf-recursive ps-recursive uninstall-info-recursive \
	uninstall-recursive
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
am__vpath_adj = case $$p in \
    $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
    *) f=$$p;; \
  esac;
am__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
am__installdirs = "$(DESTDIR)$(pkgdatadir)"
pkgdataDATA_INSTALL = $(INSTALL_DATA)
DATA = $(pkgdata_DATA)
ETAGS = etags
CTAGS = ctags
DIST_SUBDIRS = $(SUBDIRS)
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
am__remove_distdir = \
  { test ! -d $(distdir) \
    || { find $(distdir) -type d ! -perm -200 -exec chmod u+w {} ';' \
         && rm -fr $(distdir); }; }
DIST_ARCHIVES = $(distdir).tar.gz
GZIP_ENV = --best
distuninstallcheck_listfiles = find . -type f -print
distcleancheck_listfiles = find . -type f -print
pkgdatadir = $(datadir)/doc/m17n
ACLOCAL = ${SHELL} /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/missing --run aclocal-1.9
AMDEP_FALSE = #
AMDEP_TRUE = 
AMTAR = ${SHELL} /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/missing --run tar
AUTOCONF = ${SHELL} /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/missing --run autoconf
AUTOHEADER = ${SHELL} /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/missing --run autoheader
AUTOMAKE = ${SHELL} /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/missing --run automake-1.9
AWK = gawk
CC = cc
CCDEPMODE = depmode=gcc3
CFLAGS = -fno-common
CPPFLAGS = 
CYGPATH_W = echo
DEFS = -DPACKAGE_NAME=\"m17n-docs\" -DPACKAGE_TARNAME=\"m17n-docs\" -DPACKAGE_VERSION=\"1.4.0\" -DPACKAGE_STRING=\"m17n-docs\ 1.4.0\" -DPACKAGE_BUGREPORT=\"bugs-m17n-lib@m17n.org\" -DPACKAGE=\"m17n-docs\" -DVERSION=\"1.4.0\"
DEPDIR = .deps
ECHO_C = 
ECHO_N = -n
ECHO_T = 
EXEEXT = 
HAVEDOXYGEN = 
INSTALL_DATA = install  -o root -g wheel -m 444
INSTALL_PROGRAM = install  -s -o root -g wheel -m 555
INSTALL_SCRIPT = install  -o root -g wheel -m 555
INSTALL_STRIP_PROGRAM = ${SHELL} $(install_sh) -c -s
LATEX = 
LDFLAGS = 
LIBOBJS = 
LIBS = 
LTLIBOBJS = 
M17NDB = 
M17NLIB = 
M17N_CFLAGS = 
M17N_LIBS = 
MAINT = #
MAINTAINER_MODE_FALSE = 
MAINTAINER_MODE_TRUE = #
MAKEINFO = ${SHELL} /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/missing --run makeinfo
OBJEXT = 
PACKAGE = m17n-docs
PACKAGE_BUGREPORT = bugs-m17n-lib@m17n.org
PACKAGE_NAME = m17n-docs
PACKAGE_STRING = m17n-docs 1.4.0
PACKAGE_TARNAME = m17n-docs
PACKAGE_VERSION = 1.4.0
PATH_SEPARATOR = :
PKG_CONFIG = 
PLATEX = 
RUBY = 
SET_MAKE = 
SHELL = /bin/sh
STRIP = 
VERSION = 1.4.0
ac_ct_CC = 
am__fastdepCC_FALSE = #
am__fastdepCC_TRUE = 
am__include = include
am__leading_dot = .
am__quote = 
am__tar = ${AMTAR} chof - "$$tardir"
am__untar = ${AMTAR} xf -
bindir = ${exec_prefix}/bin
build_alias = i386-unknown-gnu
datadir = ${datarootdir}
datarootdir = ${prefix}/share
docdir = ${datarootdir}/doc/${PACKAGE_TARNAME}
dvidir = ${docdir}
exec_prefix = ${prefix}
host_alias = i386-unknown-gnu
htmldir = ${docdir}
includedir = ${prefix}/include
infodir = ${datarootdir}/info
install_sh = /mnt/gmirror/ports/devel/m17n-docs/work/m17n-docs-1.4.0a/install-sh
libdir = ${exec_prefix}/lib
libexecdir = ${exec_prefix}/libexec
localedir = ${datarootdir}/locale
localstatedir = ${prefix}/var
mandir = ${datarootdir}/man
mkdir_p = mkdir -p --
oldincludedir = /usr/include
pdfdir = ${docdir}
prefix = 
program_transform_name = s,x,x,
psdir = ${docdir}
sbindir = ${exec_prefix}/sbin
sharedstatedir = ${prefix}/com
sysconfdir = ${prefix}/etc
target_alias = i386-unknown-gnu
SUBDIRS = utils
pkgdata_DATA = \
	usr/html/index.html \
	usr/latex/m17n-lib.dvi usr/latex/m17n-lib.ps \
	man/man1/m17n-config.1 \
	man/man3/m17nIntro.3m17n \
	man/man5/mdbGeneral.5

EXTRA_DIST = usr/html usr/latex/m17n-lib.dvi usr/latex/m17n-lib.ps \
	man/man1 man/man3 man/man5 \
	ja/html ja/latex/m17n-lib-ja.dvi ja/latex/m17n-lib-ja.ps


#
# The followings are for maintainers only.
#
#PROJECT_NAME_EN = "The m17n Library"
#PROJECT_NAME_JA = "m17n ライブラリ"
#PROJECT_VERSION = 1.4.0
#DOXYGEN = doxygen
#EXAMPLE_PROGS = \
#	/example/mconv.c \
#	/example/mview.c \
#	/example/mdate.c \
#	/example/mdump.c \
#	/example/medit.c \
#	/example/mimx-anthy.c \
#	/example/mimx-ispell.c

#DBFORMAT = \
#	/FORMATS

#MAN1 = data/m17n-config.txt data/m17n-db.txt ${EXAMPLE_PROGS}
#MAN3 = /src/m17n-core.h \
#	/src/m17n.h \
#	/src/m17n-gui.h \
#	/src/m17n-X.h \
#	/src/m17n-misc.h \
#	/src

#MAN5 = ${DBFORMAT}
#SRCALL = \
#	mainpage.txt \
#	${MAN3} \
#	data/m17n-config.txt data/m17n-db.txt data/exprog.txt \
#	data/dbformat.txt data/dbdata.txt data/dbtutorial.txt fdl.txt

#DBDATA = $(shell echo /*.{dir,fst,tbl} /MIM/*.mim /FLT/*.flt /LANGDATA/LANGUAGE.tbl)
#DBIMAGE = $(shell echo images/*.png images/*.eps)
#HTML_USR_TARGET = usr/html/index.html usr/html/parrot.png
#HTML_JA_TARGET = ja/html/index.html ja/html/parrot.png
#HTML_DEV_TARGET = dev/html/index.html dev/html/parrot.png
#HTML_TARGET = ${HTML_USR_TARGET} ${HTML_JA_TARGET} ${HTML_DEV_TARGET}
#LATEX_USR_TARGET = usr/latex/m17n-lib.dvi usr/latex/m17n-lib.ps
#LATEX_JA_TARGET = ja/latex/m17n-lib.dvi ja/latex/m17n-lib.ps
#LATEX_DEV_TARGET = dev/latex/m17n-lib.dvi dev/latex/m17n-lib.ps
#LATEX_TARGET = ${LATEX_USR_TARGET} ${LATEX_JA_TARGET} ${LATEX_DEV_TARGET}
#MAN_TARGET = \
#	man/man1/m17n-config.1 \
#	man/man1/m17n-db.1 \
#	man/man3/m17nIntro.3m17n \
#	man/man5/mdbGeneral.5

#TARGET = ${HTML_TARGET} ${LATEX_TARGET} ${MAN_TARGET}
#CLEANFILES = doxyfile-* ${TARGET} *.tar.gz warning *~
#WEBDIR = /project/web/extra/m17n-lib
all: all-recursive

.SUFFIXES:
am--refresh:
	@:
$(srcdir)/Makefile.in: # $(srcdir)/Makefile.am  $(am__configure_deps)
	@for dep in $?; do \
	  case '$(am__configure_deps)' in \
	    *$$dep*) \
	      echo ' cd $(srcdir) && $(AUTOMAKE) --gnu '; \
	      cd $(srcdir) && $(AUTOMAKE) --gnu  \
		&& exit 0; \
	      exit 1;; \
	  esac; \
	done; \
	echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu  Makefile'; \
	cd $(top_srcdir) && \
	  $(AUTOMAKE) --gnu  Makefile
.PRECIOUS: Makefile
Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
	@case '$?' in \
	  *config.status*) \
	    echo ' $(SHELL) ./config.status'; \
	    $(SHELL) ./config.status;; \
	  *) \
	    echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe)'; \
	    cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__depfiles_maybe);; \
	esac;

$(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
	$(SHELL) ./config.status --recheck

$(top_srcdir)/configure: # $(am__configure_deps)
	cd $(srcdir) && $(AUTOCONF)
$(ACLOCAL_M4): # $(am__aclocal_m4_deps)
	cd $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
uninstall-info-am:

uninstall-pkgdataDATA:
	@$(NORMAL_UNINSTALL)
	@list='$(pkgdata_DATA)'; for p in $$list; do \
	  f=$(am__strip_dir) \
	  echo " rm -f '$(DESTDIR)$(pkgdatadir)/$$f'"; \
	  rm -f "$(DESTDIR)$(pkgdatadir)/$$f"; \
	done

# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
# To change the values of `make' variables: instead of editing Makefiles,
# (1) if the variable is set in `config.status', edit `config.status'
#     (which will cause the Makefiles to be regenerated when you run `make');
# (2) otherwise, pass the desired values on the `make' command line.
$(RECURSIVE_TARGETS):
	@failcom='exit 1'; \
	for f in x $$MAKEFLAGS; do \
	  case $$f in \
	    *=* | --[!k]*);; \
	    *k*) failcom='fail=yes';; \
	  esac; \
	done; \
	dot_seen=no; \
	target=`echo $@ | sed s/-recursive//`; \
	list='$(SUBDIRS)'; for subdir in $$list; do \
	  echo "Making $$target in $$subdir"; \
	  if test "$$subdir" = "."; then \
	    dot_seen=yes; \
	    local_target="$$target-am"; \
	  else \
	    local_target="$$target"; \
	  fi; \
	  (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
	  || eval $$failcom; \
	done; \
	if test "$$dot_seen" = "no"; then \
	  $(MAKE) $(AM_MAKEFLAGS) "$$target-am" || exit 1; \
	fi; test -z "$$fail"

mostlyclean-recursive clean-recursive distclean-recursive \
maintainer-clean-recursive:
	@failcom='exit 1'; \
	for f in x $$MAKEFLAGS; do \
	  case $$f in \
	    *=* | --[!k]*);; \
	    *k*) failcom='fail=yes';; \
	  esac; \
	done; \
	dot_seen=no; \
	case "$@" in \
	  distclean-* | maintainer-clean-*) list='$(DIST_SUBDIRS)' ;; \
	  *) list='$(SUBDIRS)' ;; \
	esac; \
	rev=''; for subdir in $$list; do \
	  if test "$$subdir" = "."; then :; else \
	    rev="$$subdir $$rev"; \
	  fi; \
	done; \
	rev="$$rev ."; \
	target=`echo $@ | sed s/-recursive//`; \
	for subdir in $$rev; do \
	  echo "Making $$target in $$subdir"; \
	  if test "$$subdir" = "."; then \
	    local_target="$$target-am"; \
	  else \
	    local_target="$$target"; \
	  fi; \
	  (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) $$local_target) \
	  || eval $$failcom; \
	done && test -z "$$fail"
tags-recursive:
	list='$(SUBDIRS)'; for subdir in $$list; do \
	  test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) tags); \
	done
ctags-recursive:
	list='$(SUBDIRS)'; for subdir in $$list; do \
	  test "$$subdir" = . || (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
	done

ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
	list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
	unique=`for i in $$list; do \
	    if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
	  done | \
	  $(AWK) '    { files[$$0] = 1; } \
	       END { for (i in files) print i; }'`; \
	mkid -fID $$unique
tags: TAGS

TAGS: tags-recursive $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
		$(TAGS_FILES) $(LISP)
	tags=; \
	here=`pwd`; \
	if ($(ETAGS) --etags-include --version) >/dev/null 2>&1; then \
	  include_option=--etags-include; \
	  empty_fix=.; \
	else \
	  include_option=--include; \
	  empty_fix=; \
	fi; \
	list='$(SUBDIRS)'; for subdir in $$list; do \
	  if test "$$subdir" = .; then :; else \
	    test ! -f $$subdir/TAGS || \
	      tags="$$tags $$include_option=$$here/$$subdir/TAGS"; \
	  fi; \
	done; \
	list='$(SOURCES) $(HEADERS)  $(LISP) $(TAGS_FILES)'; \
	unique=`for i in $$list; do \
	    if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
	  done | \
	  $(AWK) '    { files[$$0] = 1; } \
	       END { for (i in files) print i; }'`; \
	if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
	  test -n "$$unique" || unique=$$empty_fix; \
	  $(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
	    $$tags $$unique; \
	fi
ctags: CTAGS
CTAGS: ctags-recursive $(HEADERS) $(SOURCES)  $(TAGS_DEPENDENCIES) \
		$(TAGS_FILES) $(LISP)
	tags=; \
	here=`pwd`; \
	list='$(SOURCES) $(HEADERS)  $(LISP) $(TAGS_FILES)'; \
	unique=`for i in $$list; do \
	    if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
	  done | \
	  $(AWK) '    { files[$$0] = 1; } \
	       END { for (i in files) print i; }'`; \
	test -z "$(CTAGS_ARGS)$$tags$$unique" \
	  || $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
	     $$tags $$unique

GTAGS:
	here=`$(am__cd) $(top_builddir) && pwd` \
	  && cd $(top_srcdir) \
	  && gtags -i $(GTAGS_ARGS) $$here

distclean-tags:
	-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags

distdir: $(DISTFILES)
	$(am__remove_distdir)
	mkdir $(distdir)
	$(mkdir_p) $(distdir)/ja $(distdir)/ja/latex $(distdir)/man $(distdir)/usr $(distdir)/usr/latex
	@srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`; \
	topsrcdirstrip=`echo "$(top_srcdir)" | sed 's|.|.|g'`; \
	list='$(DISTFILES)'; for file in $$list; do \
	  case $$file in \
	    $(srcdir)/*) file=`echo "$$file" | sed "s|^$$srcdirstrip/||"`;; \
	    $(top_srcdir)/*) file=`echo "$$file" | sed "s|^$$topsrcdirstrip/|$(top_builddir)/|"`;; \
	  esac; \
	  if test -f $$file || test -d $$file; then d=.; else d=$(srcdir); fi; \
	  dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
	  if test "$$dir" != "$$file" && test "$$dir" != "."; then \
	    dir="/$$dir"; \
	    $(mkdir_p) "$(distdir)$$dir"; \
	  else \
	    dir=''; \
	  fi; \
	  if test -d $$d/$$file; then \
	    if test -d $(srcdir)/$$file && test $$d != $(srcdir); then \
	      cp -pR $(srcdir)/$$file $(distdir)$$dir || exit 1; \
	    fi; \
	    cp -pR $$d/$$file $(distdir)$$dir || exit 1; \
	  else \
	    test -f $(distdir)/$$file \
	    || cp -p $$d/$$file $(distdir)/$$file \
	    || exit 1; \
	  fi; \
	done
	list='$(DIST_SUBDIRS)'; for subdir in $$list; do \
	  if test "$$subdir" = .; then :; else \
	    test -d "$(distdir)/$$subdir" \
	    || $(mkdir_p) "$(distdir)/$$subdir" \
	    || exit 1; \
	    distdir=`$(am__cd) $(distdir) && pwd`; \
	    top_distdir=`$(am__cd) $(top_distdir) && pwd`; \
	    (cd $$subdir && \
	      $(MAKE) $(AM_MAKEFLAGS) \
	        top_distdir="$$top_distdir" \
	        distdir="$$distdir/$$subdir" \
	        distdir) \
	      || exit 1; \
	  fi; \
	done
	-find $(distdir) -type d ! -perm -777 -exec chmod a+rwx {} \; -o \
	  ! -type d ! -perm -444 -links 1 -exec chmod a+r {} \; -o \
	  ! -type d ! -perm -400 -exec chmod a+r {} \; -o \
	  ! -type d ! -perm -444 -exec $(SHELL) $(install_sh) -c -m a+r {} {} \; \
	|| chmod -R a+r $(distdir)
dist-gzip: distdir
	tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
	$(am__remove_distdir)

dist-bzip2: distdir
	tardir=$(distdir) && $(am__tar) | bzip2 -9 -c >$(distdir).tar.bz2
	$(am__remove_distdir)

dist-tarZ: distdir
	tardir=$(distdir) && $(am__tar) | compress -c >$(distdir).tar.Z
	$(am__remove_distdir)

dist-shar: distdir
	shar $(distdir) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).shar.gz
	$(am__remove_distdir)

dist-zip: distdir
	-rm -f $(distdir).zip
	zip -rq $(distdir).zip $(distdir)
	$(am__remove_distdir)

dist dist-all: distdir
	tardir=$(distdir) && $(am__tar) | GZIP=$(GZIP_ENV) gzip -c >$(distdir).tar.gz
	$(am__remove_distdir)

# This target untars the dist file and tries a VPATH configuration.  Then
# it guarantees that the distribution is self-contained by making another
# tarfile.
distcheck: dist
	case '$(DIST_ARCHIVES)' in \
	*.tar.gz*) \
	  GZIP=$(GZIP_ENV) gunzip -c $(distdir).tar.gz | $(am__untar) ;;\
	*.tar.bz2*) \
	  bunzip2 -c $(distdir).tar.bz2 | $(am__untar) ;;\
	*.tar.Z*) \
	  uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
	*.shar.gz*) \
	  GZIP=$(GZIP_ENV) gunzip -c $(distdir).shar.gz | unshar ;;\
	*.zip*) \
	  unzip $(distdir).zip ;;\
	esac
	chmod -R a-w $(distdir); chmod a+w $(distdir)
	mkdir $(distdir)/_build
	mkdir $(distdir)/_inst
	chmod a-w $(distdir)
	dc_install_base=`$(am__cd) $(distdir)/_inst && pwd | sed -e 's,^[^:\\/]:[\\/],/,'` \
	  && dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" \
	  && cd $(distdir)/_build \
	  && ../configure --srcdir=.. --prefix="$$dc_install_base" \
	    $(DISTCHECK_CONFIGURE_FLAGS) \
	  && $(MAKE) $(AM_MAKEFLAGS) \
	  && $(MAKE) $(AM_MAKEFLAGS) dvi \
	  && $(MAKE) $(AM_MAKEFLAGS) check \
	  && $(MAKE) $(AM_MAKEFLAGS) install \
	  && $(MAKE) $(AM_MAKEFLAGS) installcheck \
	  && $(MAKE) $(AM_MAKEFLAGS) uninstall \
	  && $(MAKE) $(AM_MAKEFLAGS) distuninstallcheck_dir="$$dc_install_base" \
	        distuninstallcheck \
	  && chmod -R a-w "$$dc_install_base" \
	  && ({ \
	       (cd ../.. && umask 077 && mkdir "$$dc_destdir") \
	       && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" install \
	       && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" uninstall \
	       && $(MAKE) $(AM_MAKEFLAGS) DESTDIR="$$dc_destdir" \
	            distuninstallcheck_dir="$$dc_destdir" distuninstallcheck; \
	      } || { rm -rf "$$dc_destdir"; exit 1; }) \
	  && rm -rf "$$dc_destdir" \
	  && $(MAKE) $(AM_MAKEFLAGS) dist \
	  && rm -rf $(DIST_ARCHIVES) \
	  && $(MAKE) $(AM_MAKEFLAGS) distcleancheck
	$(am__remove_distdir)
	@(echo "$(distdir) archives ready for distribution: "; \
	  list='$(DIST_ARCHIVES)'; for i in $$list; do echo $$i; done) | \
	  sed -e '1{h;s/./=/g;p;x;}' -e '$${p;x;}'
distuninstallcheck:
	@cd $(distuninstallcheck_dir) \
	&& test `$(distuninstallcheck_listfiles) | wc -l` -le 1 \
	   || { echo "ERROR: files left after uninstall:" ; \
	        if test -n "$(DESTDIR)"; then \
	          echo "  (check DESTDIR support)"; \
	        fi ; \
	        $(distuninstallcheck_listfiles) ; \
	        exit 1; } >&2
distcleancheck: distclean
	@if test '$(srcdir)' = . ; then \
	  echo "ERROR: distcleancheck can only run from a VPATH build" ; \
	  exit 1 ; \
	fi
	@test `$(distcleancheck_listfiles) | wc -l` -eq 0 \
	  || { echo "ERROR: files left in build directory after distclean:" ; \
	       $(distcleancheck_listfiles) ; \
	       exit 1; } >&2
check-am: all-am
check: check-recursive
all-am: Makefile $(DATA)
installdirs: installdirs-recursive
installdirs-am:
	for dir in "$(DESTDIR)$(pkgdatadir)"; do \
	  test -z "$$dir" || $(mkdir_p) "$$dir"; \
	done
install: install-recursive
install-exec: install-exec-recursive
install-data: install-data-recursive
uninstall: uninstall-recursive

install-am: all-am
	@$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am

installcheck: installcheck-recursive
install-strip:
	$(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
	  install_sh_PROGRAM="$(INSTALL_STRIP_PROGRAM)" INSTALL_STRIP_FLAG=-s \
	  `test -z '$(STRIP)' || \
	    echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
mostlyclean-generic:

clean-generic:
	-test -z "$(CLEANFILES)" || rm -f $(CLEANFILES)

distclean-generic:
	-test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)

maintainer-clean-generic:
	@echo "This command is intended for maintainers to use"
	@echo "it deletes files that may require special tools to rebuild."
clean-local:
clean: clean-recursive

clean-am: clean-generic clean-local mostlyclean-am

distclean: distclean-recursive
	-rm -f $(am__CONFIG_DISTCLEAN_FILES)
	-rm -f Makefile
distclean-am: clean-am distclean-generic distclean-tags

dvi: dvi-recursive

dvi-am:

html: html-recursive

info: info-recursive

info-am:

install-data-am: install-pkgdataDATA

install-exec-am:

install-info: install-info-recursive

install-man:

installcheck-am:

maintainer-clean: maintainer-clean-recursive
	-rm -f $(am__CONFIG_DISTCLEAN_FILES)
	-rm -rf $(top_srcdir)/autom4te.cache
	-rm -f Makefile
maintainer-clean-am: distclean-am maintainer-clean-generic

mostlyclean: mostlyclean-recursive

mostlyclean-am: mostlyclean-generic

pdf: pdf-recursive

pdf-am:

ps: ps-recursive

ps-am:

uninstall-am: uninstall-info-am uninstall-pkgdataDATA

uninstall-info: uninstall-info-recursive

.PHONY: $(RECURSIVE_TARGETS) CTAGS GTAGS all all-am am--refresh check \
	check-am clean clean-generic clean-local clean-recursive ctags \
	ctags-recursive dist dist-all dist-bzip2 dist-gzip dist-shar \
	dist-tarZ dist-zip distcheck distclean distclean-generic \
	distclean-recursive distclean-tags distcleancheck distdir \
	distuninstallcheck dvi dvi-am html html-am info info-am \
	install install-am install-data install-data-am install-exec \
	install-exec-am install-info install-info-am install-man \
	install-pkgdataDATA install-strip installcheck installcheck-am \
	installdirs installdirs-am maintainer-clean \
	maintainer-clean-generic maintainer-clean-recursive \
	mostlyclean mostlyclean-generic mostlyclean-recursive pdf \
	pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
	uninstall-info-am uninstall-pkgdataDATA


install-pkgdataDATA: $(pkgdata_DATA)
	$(mkinstalldirs) $(pkgdatadir)/html
	$(mkinstalldirs) $(mandir)/man1 $(mandir)/man3 $(mandir)/man5
	$(INSTALL_DATA) usr/latex/m17n-lib.dvi $(pkgdatadir)/m17n-lib.dvi
	$(INSTALL_DATA) usr/latex/m17n-lib.ps $(pkgdatadir)/m17n-lib.ps
	cd usr/html; \
	  for f in *.html *.png; do \
	    $(INSTALL_DATA) $$f $(pkgdatadir)/html/$$f; \
	  done
	cd man/man1; \
	  for f in *.1; do $(INSTALL_DATA) $$f $(mandir)/man1/$$f; done
	cd man/man3; \
	  for f in *.3m17n; do $(INSTALL_DATA) $$f $(mandir)/man3/$$f; done
	cd man/man5; \
	  for f in *.5; do $(INSTALL_DATA) $$f $(mandir)/man5/$$f; done

#usr-html html-usr: ${HTML_USR_TARGET}
#ja-html html-ja: ${HTML_JA_TARGET}
#dev-html html-dev: ${HTML_DEV_TARGET}

#usr-latex latex-usr: ${LATEX_USR_TARGET}
#ja-latex latex-ja: ${LATEX_JA_TARGET}
#dev-latex latex-dev: ${LATEX_DEV_TARGET}

#usr-man man-usr: ${MAN_TARGET}

#usr: usr-html usr-latex usr-man
#ja: ja-html ja-latex
#dev: dev-html dev-latex

#html: usr-html ja-html dev-html
#latex: usr-latex ja-latex dev-latex
#man: usr-man

#doxyfile-html: doxyfile ${SRCALL}
#	sed -e 's|%PROJECT_NUMBER%|1.4.0|' \
#	    -e 's|%INPUT%|${SRCALL}|' \
#	    -e 's|%GENERATE_HTML%|YES|' \
#	    -e 's|%GENERATE_LATEX%|NO|' \
#	    -e 's|%GENERATE_MAN%|NO|' \
#	    -e 's|%ENABLED_SECTIONS%|FOR-HTML|' \
#	  < $< >$@

#doxyfile-html.usr: doxyfile-html
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_EN}|' \
#	    -e 's/%USR_JA_DEV%/usr/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/English/' \
#	  < $< >$@

#doxyfile-html.dev: doxyfile-html
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_EN}|' \
#	    -e 's/%USR_JA_DEV%/dev/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/English/' \
#	  < $< >$@

#doxyfile-html.ja: doxyfile-html
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_JA}|' \
#	    -e 's/%USR_JA_DEV%/ja/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/Japanese/' \
#	  < $< >$@

#doxyfile-latex: doxyfile ${SRCALL}
#	sed -e 's|%PROJECT_NUMBER%|1.4.0|' \
#	    -e 's|%INPUT%|${SRCALL}|' \
#	    -e 's|%GENERATE_HTML%|NO|' \
#	    -e 's|%GENERATE_LATEX%|YES|' \
#	    -e 's|%GENERATE_MAN%|NO|' \
#	    -e 's|%ENABLED_SECTIONS%|FOR-LATEX|' \
#	  < $< >$@

#doxyfile-latex.usr: doxyfile-latex
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_EN}|' \
#	    -e 's/%USR_JA_DEV%/usr/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/English/' \
#	  < $< >$@

#doxyfile-latex.dev: doxyfile-latex
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_EN}|' \
#	    -e 's/%USR_JA_DEV%/dev/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/English/' \
#	  < $< >$@

#doxyfile-latex.ja: doxyfile-latex
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_JA}|' \
#	    -e 's/%USR_JA_DEV%/ja/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/Japanese/' \
#	  < $< >$@

#doxyfile-man1: doxyfile ${SRCALL}
#	sed -e 's|%PROJECT_NUMBER%|1.4.0|' \
#	    -e 's|%INPUT%|${MAN1}|' \
#	    -e 's|%GENERATE_HTML%|NO|' \
#	    -e 's|%GENERATE_LATEX%|NO|' \
#	    -e 's|%GENERATE_MAN%|YES|' \
#	    -e 's|%MAN_EXTENSION%|.1|' \
#	    -e 's|%ENABLED_SECTIONS%|FOR-MAN|' \
#	  < $< >$@

#doxyfile-man3: doxyfile ${SRCALL}
#	sed -e 's|%PROJECT_NUMBER%|1.4.0|' \
#	    -e 's|%INPUT%|${MAN3}|' \
#	    -e 's|%GENERATE_HTML%|NO|' \
#	    -e 's|%GENERATE_LATEX%|NO|' \
#	    -e 's|%GENERATE_MAN%|YES|' \
#	    -e 's|%MAN_EXTENSION%|.3m17n|' \
#	    -e 's|%ENABLED_SECTIONS%|FOR-MAN|' \
#	  < $< >$@

#doxyfile-man5: doxyfile ${SRCALL}
#	sed -e 's|%PROJECT_NUMBER%|1.4.0|' \
#	    -e 's|%INPUT%|${MAN5}|' \
#	    -e 's|%GENERATE_HTML%|NO|' \
#	    -e 's|%GENERATE_LATEX%|NO|' \
#	    -e 's|%GENERATE_MAN%|YES|' \
#	    -e 's|%MAN_EXTENSION%|.5|' \
#	    -e 's|%ENABLED_SECTIONS%|FOR-MAN|' \
#	  < $< >$@

#doxyfile-man%.usr: doxyfile-man%
#	sed -e 's|%PROJECT_NAME%|${PROJECT_NAME_EN}|' \
#	    -e 's/%USR_JA_DEV%/usr/g' \
#	    -e 's/%OUTPUT_LANGUAGE%/English/' \
#	  < $< >$@

#data/exprog.txt: ${EXAMPLE_PROGS} utils/exprog.sh
#	utils/exprog.sh ${EXAMPLE_PROGS} > $@

#data/dbdata.txt: ${DBDATA} ${DBIMAGE} /mdb.dir utils/dbdata.awk utils/dbdata.sh utils/imdoc.c
#	(cd utils; make)
#	gawk -f utils/dbdata.awk /mdb.dir > $@

#data/dbformat.txt: ${DBFORMAT} utils/dbformat.sh
#	utils/dbformat.sh ${DBFORMAT} > $@

#data/dbtutorial.txt: ${DBFORMAT} utils/dbtutorial.sh
#	utils/dbtutorial.sh ${DBFORMAT} > $@

#data/m17n-config.txt: /m17n-config.in
#	sed -n -e '/\/\*\*\*/,/\*\// p' < $< > $@

#data/m17n-db.txt: /m17n-db.in
#	sed -n -e '/\/\*\*\*/,/\*\// p' < $< > $@

#%/html/index.html: doxyfile-html.% header.%.html footer.%.html ${SRCALL} \
#			utils/%_filter.rb m17n-lib.css
#	rm -f `dirname $@`/*.html
#	${DOXYGEN} $<
#	cp images/icon-*.png `dirname $@`
#	cd `dirname $@`; rm -f *_8c* *_8h* *_8txt* dirs.html dir_* files.html
#	echo 'code { font-weight: bold }' >> `dirname $@`/doxygen.css

#%/html/parrot.png: parrot.png
#	cp $< $@

#%/latex/refman.tex: doxyfile-latex.% ${SRCALL} utils/%_filter.rb
#	rm -rf `dirname $@`
#	${DOXYGEN} $<
#	cd `dirname $@`; rm -f *_8c* *_8h* *_8txt* dirs.tex dir_* files.tex

#%/latex/m17n-lib.dvi: %/latex/refman.tex styles/m17n-lib.sty utils/latex.sh
#	-utils/latex.sh `dirname $@` latex

#%/latex/m17n-lib.ps: %/latex/m17n-lib.dvi utils/dvips.sh
#	utils/dvips.sh `dirname $@` dvips
#	emacs -batch -q -l utils/mokuji.el -f write-mokuji $@

#%/latex/m17n-lib.pdf: %/latex/m17n-lib.tex data-%/m17n-lib.sty utils/latex.sh
#	utils/latex.sh `dirname $@` pdflatex

#%/man/man1/m17n-config.1: doxyfile-man1.% ${MAN1} utils/%_filter.rb
#	rm -rf `dirname $@`
#	cp doxyfile-man1.usr temp
#	${DOXYGEN} $<
#	cd `dirname $@`; rm -f _*.1 *.c.1 *.txt.1

#%/man/man3/m17nIntro.3m17n: doxyfile-man3.% ${MAN3} utils/%_filter.rb
#	rm -rf `dirname $@`
#	${DOXYGEN} $<

#%/man/man5/mdbGeneral.5: doxyfile-man5.% ${MAN5} utils/%_filter.rb
#	rm -rf `dirname $@`
#	${DOXYGEN} $<

#sample/man3/SampleGroup.3: sample.c
#	[ -d sample ] || mkdir sample
#	[ -d sample/man3 ] || mkdir sample/man3
#	-${DOXYGEN} -g doxytemp
#	echo "INPUT = sample.c" >> doxytemp
#	echo "GENERATE_LATEX = NO" >> doxytemp
#	echo "GENERATE_HTML = NO" >> doxytemp
#	echo "GENERATE_MAN = YES" >> doxytemp
#	echo "MAN_OUTPUT = sample" >> doxytemp
#	echo "OPTIMIZE_OUTPUT_FOR_C  = yes" >> doxytemp
#	${DOXYGEN} doxytemp
#	rm -rf doxytemp

#man/man1/%: usr/man/man1/% sample/man3/SampleGroup.3 utils/mkman.rb 
#	$(mkinstalldirs) man/man1
#	rm -rf doxywork man/man1/*
#	ruby utils/mkman.rb 1 usr/man/man1 man/man1

#man/man3/%: usr/man/man3/% sample/man3/SampleGroup.3 utils/mkman.rb 
#	$(mkinstalldirs) man/man3
#	rm -rf doxywork man/man3/*
#	ruby utils/mkman.rb 3m17n usr/man/man3m17n man/man3

#man/man5/%: usr/man/man5/% sample/man3/SampleGroup.3 utils/mkman.rb 
#	$(mkinstalldirs) man/man5
#	rm -rf doxywork man/man5/*
#	ruby utils/mkman.rb 5 usr/man/man5 man/man5

#man/ja/man1/%: ja/man/man1/% sample/man3/SampleGroup.3 utils/mkman.rb 
#	$(mkinstalldirs) man/ja/man1
#	rm -rf doxywork man/ja/man1/*
#	ruby utils/mkman.rb 1 ja/man/man1 man/ja/man1

#man/ja/man3/%: ja/man/man3/% sample/man3/SampleGroup.3 utils/mkman.rb 
#	$(mkinstalldirs) man/ja/man3
#	rm -rf doxywork man/ja/man3/*
#	ruby utils/mkman.rb 3m17n ja/man/man3 man/ja/man3

#man/ja/man5/%: ja/man/man5/% sample/man3/SampleGroup.3 utils/mkman.rb 
#	$(mkinstalldirs) man/ja/man5
#	rm -rf doxywork man/ja/man5/*
#	ruby utils/mkman.rb 5 ja/man/man5 man/ja/man5

#clean-local:
#	rm -rf usr dev ja man doxywork

#release: dist
#	[ -d ${WEBDIR}/m17n-docs ] || mkdir ${WEBDIR}/m17n-docs
#	[ -d ${WEBDIR}/download ] || mkdir ${WEBDIR}/download
#	cd usr/html; for f in *; do \
#	  case $$f in *8c*);; *8h*);; *8txt*);; dirs.html);; dir_*);; files.html);; *) cp $$f ${WEBDIR}/m17n-docs;; esac; \
#	done
#	[ -d ${WEBDIR}-ja2/m17n-docs ] || mkdir ${WEBDIR}-ja2/m17n-docs
#	cd ja/html; for f in *; do \
#	  case $$f in *8c*);; *8h*);; *8txt*);; dirs.html);; dir_*);; files.html);; *) cp $$f ${WEBDIR}-ja2/m17n-docs;; esac; \
#	done
#	cp ${distdir}.tar.gz ${WEBDIR}/download

#.PRECIOUS: %/latex/refman.tex %/man/man3/m17nIntro.3m ${SRCALL}

# Local Variables:
# coding: utf-8
# End:
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT:


syntax highlighted by Code2HTML, v. 0.9.1