# New ports collection makefile for:	ocamlweb
# Date created:				4 February 2001
# Whom:					Patrick Doane <patrick@watson.org>
#
# $FreeBSD: ports/devel/ocamlweb/Makefile,v 1.12 2007/05/19 20:03:23 flz Exp $
#

PORTNAME=	ocamlweb
PORTVERSION=	1.34
PORTREVISION=	2
CATEGORIES=	devel
MASTER_SITES=	http://www.lri.fr/~filliatr/ftp/ocamlweb/
DISTFILES=	${DISTNAME}${EXTRACT_SUFX} ${DOCFILES}
EXTRACT_ONLY=	${DISTNAME}${EXTRACT_SUFX}

MAINTAINER=	hrs@FreeBSD.ORG
COMMENT=	A literate programming tool for Objective Caml

BUILD_DEPENDS=	ocamlc:${PORTSDIR}/lang/ocaml
RUN_DEPENDS=	latex:${PORTSDIR}/print/teTeX-base

GNU_CONFIGURE= yes

.if !defined(NOPORTDOCS)
DOCFILES=	${PORTNAME}-${PORTVERSION}-man.ps.gz
PLIST_SUB+=	PORTVERSION=${PORTVERSION}
.endif

MAN1=		ocamlweb.1

post-install:
.if !defined{NOPORTDOCS}
	@${MKDIR} ${DOCSDIR}
	@${INSTALL_DATA} ${DISTDIR}/${DOCFILES} ${DOCSDIR}
.endif

.include <bsd.port.mk>