# New ports collection makefile for: p5-DateTime-TimeZone
# Date created: 4 mai 2003
# Whom: Mathieu Arnold <m@absolight.net>
#
# $FreeBSD: ports/devel/p5-DateTime-TimeZone/Makefile,v 1.49 2007/10/26 13:59:23 mat Exp $
#
PORTNAME= DateTime-TimeZone
PORTVERSION= 0.68
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= mat@FreeBSD.org
COMMENT= Time zone object base class and factory
RUN_DEPENDS= p5-Class-Singleton>=1.03:${PORTSDIR}/devel/p5-Class-Singleton \
p5-Params-Validate>=0.72:${PORTSDIR}/devel/p5-Params-Validate
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
MAN3= DateTime::TimeZone.3 DateTime::TimeZone::Floating.3 \
DateTime::TimeZone::Local.3 DateTime::TimeZone::Local::Unix.3 \
DateTime::TimeZone::Local::VMS.3 DateTime::TimeZone::Local::Win32.3 \
DateTime::TimeZone::OffsetOnly.3 DateTime::TimeZone::OlsonDB.3 \
DateTime::TimeZone::UTC.3 DateTime::TimeZoneCatalog.3
.if !defined(NOPORTDOCS)
PORTDOCS= Changes README
post-install:
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
.endif
.include <bsd.port.post.mk>
syntax highlighted by Code2HTML, v. 0.9.1