# New ports collection makefile for:	Devel-RingBuffer
# Date created:	   28 August 2006
# Whom:		   Sergey Skvortsov <skv@protey.ru>
#
# $FreeBSD: ports/devel/p5-Devel-RingBuffer/Makefile,v 1.1 2006/08/28 09:57:10 skv Exp $
#

PORTNAME=	Devel-RingBuffer
PORTVERSION=	0.31
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=	Devel
PKGNAMEPREFIX=	p5-

MAINTAINER=	skv@FreeBSD.org
COMMENT=	Shared memory ring buffers for Perl scripts diagnosis/debug

RUN_DEPENDS=	${SITE_PERL}/${PERL_ARCH}/IPC/Mmap.pm:${PORTSDIR}/devel/p5-IPC-Mmap
BUILD_DEPENDS=	${RUN_DEPENDS}

PERL_CONFIGURE=	yes

MAN3=		Devel::RingBuffer.3 Devel::RingBuffer::Ring.3

.include <bsd.port.mk>