# New ports collection makefile for:	File-Cache
# Date created:				Mon Jan  1 11:28:15 2001
# Whom:					will
#
# $FreeBSD: ports/devel/p5-File-Cache/Makefile,v 1.8 2003/05/09 01:20:36 edwin Exp $
#

PORTNAME=	File-Cache
PORTVERSION=	0.16
CATEGORIES=	devel perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=	File
PKGNAMEPREFIX=	p5-

MAINTAINER=	ports@FreeBSD.org
COMMENT=	Perl module implementing a persistent object store

PERL_CONFIGURE=	yes

MAN3=		File::Cache.3

.include <bsd.port.pre.mk>

.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS=	${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
		${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
RUN_DEPENDS=	${BUILD_DEPENDS}
.endif

.include <bsd.port.post.mk>