# New ports collection makefile for:    p5-Test-Tester
# Date created:				May 12th 2004
# Whom:	      				Alex Kapranoff <alex@kapranoff.ru>
#
# $FreeBSD: ports/devel/p5-Test-Tester/Makefile,v 1.9 2007/10/26 20:30:08 mat Exp $
#

PORTNAME=	Test-Tester
PORTVERSION=	0.10.6
DISTVERSION=	${PORTVERSION:C/\.(.)$/\1/}
CATEGORIES=	devel perl5
MASTER_SITES=	CPAN
PKGNAMEPREFIX=	p5-

MAINTAINER=	mat@FreeBSD.org
COMMENT=	Helps to test various Test::Builder derivatives

PERL_CONFIGURE=	yes
INSTALL_TARGET=	pure_install

MAN3=		Test::Tester.3 Test::Tester::Capture.3 \
		Test::Tester::CaptureRunner.3

.if !defined(NOPORTDOCS)
PORTDOCS=	CHANGES

post-install:
	@${MKDIR} ${DOCSDIR}
	@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
	@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif

.include <bsd.port.pre.mk>

.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+=	${SITE_PERL}/Test/Builder.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS+=	${BUILD_DEPENDS}
.endif

.include <bsd.port.post.mk>