# New ports collection makefile for: p5-forks
# Date created: 2006-10-12
# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
#
# $FreeBSD: ports/devel/p5-forks/Makefile,v 1.6 2007/10/05 08:53:51 clsung Exp $
#
PORTNAME= forks
PORTVERSION= 0.26
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= SOAP/RYBSKEJ
PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Drop-in replacement for Perl threads using fork()
RUN_DEPENDS= ${SITE_PERL}/reaper.pm:${PORTSDIR}/devel/p5-reaper \
p5-Devel-Required>=0:${PORTSDIR}/devel/p5-Devel-Required \
p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= forks.3 forks::signals.3 \
forks::shared.3 \
threads::shared::array.3 \
threads::shared::handle.3 \
threads::shared::hash.3 \
threads::shared::scalar.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500702
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
.endif
.include <bsd.port.post.mk>
syntax highlighted by Code2HTML, v. 0.9.1