# New ports collection makefile for:	pecl-bbcode
# Date created:			6 Aug 2007
# Whom:				Ditesh Shashikant Gathani <ditesh@gathani.org>
#
# $FreeBSD: ports/devel/pecl-bbcode/Makefile,v 1.2 2007/12/12 19:04:57 chinsan Exp $
#

PORTNAME=	bbcode
PORTVERSION=	0.10.4
CATEGORIES=	devel pear
MASTER_SITES=	http://pecl.php.net/get/
PKGNAMEPREFIX=	pecl-
EXTRACT_SUFX=	.tgz
DIST_SUBDIR=	PECL

MAINTAINER=	ditesh@gathani.org
COMMENT=	A PECL extension which allows quick and efficient BBCode Parsing

USE_PHP=	yes
USE_PHP_BUILD=	yes
USE_PHPEXT=	yes

CONFIGURE_ARGS=	--enable-bbcode

post-patch:
	@${REINPLACE_CMD} -e 's/#include <malloc.h>/\/\/#include <malloc.h>/g' ${WRKSRC}/lib/bbcode2.c

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1