all: compile install
# Compile target. This should setup the package and compile it
# into a state ready for installation.
compile:
cd mxTextTools; \
if ! test -f Makefile; then $(MAKE) -f Makefile.pre.in boot; fi; \
$(MAKE)
# Install target. This should do the install step. If the package
# needs no further installation step (i.e. the extension is not
# needed by other extension modules), then you can leave this target
# blank.
install:
cd mxTextTools; \
$(MAKE) install
# Test target. Should do some testing of the extension. Writing
# something like 'ok' or 'works' and the end of a successful run.
test:
cd mxTextTools; \
python test.py
# Documentation target. Use this to have the documentation for
# an extension generated at the user.
doc:
# ???
# Cleanup before distributing the package
#
distclean:
cd mxTextTools; \
$(MAKE) distclean
syntax highlighted by Code2HTML, v. 0.9.1