# New ports collection makefile for:	py-twisted
# Date created:		16 August 2001
# Whom:	      		Johann Visagie <wjv@FreeBSD.org>
#
# $FreeBSD: ports/devel/py-twisted/Makefile,v 1.35 2007/07/30 09:41:23 alexbl Exp $
#

PORTNAME=	twisted
PORTVERSION=	1.3.0
PORTREVISION=	2
CATEGORIES=	devel net python
MASTER_SITES=	http://tmrc.mit.edu/mirror/twisted/
MASTER_SITE_SUBDIR=	${PORTNAME}
PKGNAMEPREFIX=	${PYTHON_PKGNAMEPREFIX}
DISTNAME=	Twisted_NoDocs-${PORTVERSION}

MAINTAINER=	ports@FreeBSD.org
COMMENT=	An event-based Python framework for internet applications

CONFLICTS=	py??-twistedCore-[0-9]*

# - Note that Twisted ships with some graphical examples and clients that
#   require PyGNOME to run.  These are not central to the funcitoning of
#   Twisted, but the user should feel free to install x11-toolits/py-gnome
#   separately if desired.

USE_BZIP2=	yes
USE_PYTHON=	2.2+
USE_PYDISTUTILS=	yes
PYDISTUTILS_PKGNAME=	Twisted
PYDISTUTILS_PKGVERSION=	1.3.0rc1

PLIST_SUB+=	S=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}

WRKSRC=		${WRKDIR}/Twisted-${PORTVERSION}

post-install:
	@ ${MKDIR} ${DATADIR}/admin
	@ ${INSTALL_SCRIPT} ${WRKSRC}/admin/accepttests \
	  ${WRKSRC}/admin/runtests ${DATADIR}/admin

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1