# ports collection makefile for:	readline
# Date created:				10 December 2003
# Whom:					Frank Laszlo <laszlof@vonostingroup.com>
#
# $FreeBSD: ports/devel/readline/Makefile,v 1.13 2007/08/23 19:26:36 laszlof Exp $
#

PORTNAME=	readline
PORTVERSION=	5.2
PORTREVISION=	1
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GNU} \
		ftp://ftp.cwru.edu/pub/bash/
MASTER_SITE_SUBDIR=	${PORTNAME}

PATCH_SITES=	ftp://ftp.gnu.org/gnu/readline/${PORTNAME}-${PORTVERSION}-patches/ \
		ftp://ftp.cwru.edu/pub/bash/${PORTNAME}-${PORTVERSION}-patches/
PATCHFILES=	readline52-001 readline52-002 readline52-003 readline52-004 \
		readline52-005 readline52-006 readline52-007

MAINTAINER=	laszlof@FreeBSD.org
COMMENT=	A library for editing command lines as they are typed

GNU_CONFIGURE=	yes
USE_LDCONFIG=	yes

INFO=		readline rluserman history
MAN3=		readline.3 history.3

.include <bsd.port.pre.mk>

.if ${ARCH} == "sparc64"
EXTRA_PATCHES+=	${FILESDIR}/support_shobj-conf.diff
.endif

pre-configure:
.if !defined(WITHOUT_TERMCAP)
	${REINPLACE_CMD} "s/SHOBJ_LDFLAGS =/SHOBJ_LDFLAGS = -ltermcap/" ${WRKSRC}/shlib/Makefile.in
.endif

.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1