# New ports collection makefile for: Ruby-property
# Date created: 7 Aug 2000
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD: ports/devel/ruby-property/Makefile,v 1.14 2005/11/28 04:40:20 fenner Exp $
#
PORTNAME= property
PORTVERSION= 19990308
CATEGORIES= devel ruby
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fenner/ruby-contrib
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple properties scheme for Ruby
USE_RUBY= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
post-patch:
${RUBY} -i -pe 'gsub /rubyapi\.css/, "../rubyapi.css"' ${WRKSRC}/Properties-ja.html
do-install:
${INSTALL_DATA} ${WRKSRC}/property.rb ${RUBY_SITELIBDIR}
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}/ja
.for f in property-example.rb test.default property.README Properties.html rubyapi.css
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
.endfor
.for f in property.README.ja Properties-ja.html
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja
.endfor
.endif
.include <bsd.port.mk>
syntax highlighted by Code2HTML, v. 0.9.1