# New ports collection makefile for:	TclTrf
# Date created:			May 22, 2000
# Whom:				Mikhail Teterin <mi@aldan.algebra.com>
#
# $FreeBSD: ports/devel/tcl-memchan/Makefile,v 1.9 2003/10/27 21:03:04 mi Exp $
#

PORTNAME=	memchan
PORTVERSION=	2.2a4
CATEGORIES=	devel tcl${TCL_VER:S/.//}
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
PKGNAMEPREFIX=	tcl-
DISTNAME=	Memchan${PORTVERSION}
MASTER_SITE_SUBDIR=${PORTNAME}

MAINTAINER=	mi@aldan.algebra.com
COMMENT=	Two new channel types for in-memory channels in TCL8

BUILD_DEPENDS=	tclsh${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER:S/.//}

USE_BZIP2=	yes

MAKEFILE=	${FILESDIR}/Makefile.bsd
MAKE_ARGS+=	-j2

TCL_VER?=	8.4
DDIR=		${PREFIX}/lib/tcl${TCL_VER}/Trf

MAKE_ENV+=	TCL_VER=${TCL_VER} MKDIR="${MKDIR}" \
		INSTALL_DATA="${INSTALL_DATA}"

# Too bad, n is no longer an acceptable section for bsd.man.mk
MANN=	memchan.n fifo.n fifo2.n null.n

post-install:
	cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MANN} ${PREFIX}/man/mann
#.ifndef(NOPORTDOCS)
#	${MKDIR} ${DOCSDIR}
#	${CP} -pR ${WRKSRC}/doc/html/* ${DOCSDIR}
#.endif

.include <bsd.port.mk>

PLIST_SUB!=	${SETENV} TCL_VER=${TCL_VER} ${MAKE} -f ${MAKEFILE} env


syntax highlighted by Code2HTML, v. 0.9.1