# Copyright 2000, 2001, 2003, 2006 Nominum, Inc. All Rights Reserved.
prefix = /usr/local
exec_prefix = ${prefix}
bindir = ${exec_prefix}/bin
mandir = /usr/local/man
INSTALL = /usr/bin/install -c -o root -g wheel
INSTALL_PROGRAM = install -s -o root -g wheel -m 555
INSTALL_DATA = install -o root -g wheel -m 444
CC = cc
LIBOBJS =
LIBS =
DEFS = -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -Dinline= -Dsocklen_t=int
DNSCFLAGS =
DNSLIBS =
all: dnsperf resperf
dnsperf: dnsperf.o common.o $(LIBOBJS)
$(CC) $(CFLAGS) $(DEFS) $(LDFLAGS) dnsperf.o common.o $(LIBOBJS) $(LIBS) ${DNSLIBS} -lm -o dnsperf
resperf: resperf.o common.o $(LIBOBJS)
$(CC) $(CFLAGS) $(DEFS) $(LDFLAGS) resperf.o common.o $(LIBOBJS) $(LIBS) ${DNSLIBS} -lm -o resperf
common.o: common.c
$(CC) $(CFLAGS) ${DNSCFLAGS} $(DEFS) -c common.c
dnsperf.o: dnsperf.c
$(CC) $(CFLAGS) ${DNSCFLAGS} $(DEFS) -c dnsperf.c
resperf.o: resperf.c
$(CC) $(CFLAGS) ${DNSCFLAGS} $(DEFS) -c resperf.c
installdirs:
mkdir -p ${DESTDIR}${bindir}
mkdir -p ${DESTDIR}${mandir}/man1
install: all installdirs
${INSTALL_PROGRAM} dnsperf ${DESTDIR}${bindir}
${INSTALL_PROGRAM} resperf ${DESTDIR}${bindir}
${INSTALL_DATA} dnsperf.1 ${DESTDIR}${mandir}/man1
${INSTALL_DATA} resperf.1 ${DESTDIR}${mandir}/man1
clean:
rm -f *.o dnsperf resperf
distclean: clean
rm -f config.log
rm -f config.cache
rm -f config.status
rm -f Makefile
syntax highlighted by Code2HTML, v. 0.9.1