# New ports collection makefile for:	gproftpd
# Date created:		14 September 2007
# Whom:			Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD: ports/ftp/gproftpd/Makefile,v 1.2 2007/09/17 09:41:28 miwi Exp $
#

PORTNAME=	gproftpd
PORTVERSION=	8.3.2
PORTREVISION=	1
CATEGORIES=	ftp
MASTER_SITES=	http://mange.dynalias.org/linux/gproftpd/

MAINTAINER=	beech@FreeBSD.org
COMMENT=	Gtk2 Frontend for proftpd daemon

RUN_DEPENDS=	proftpd:${PORTSDIR}/ftp/proftpd

USE_GMAKE=	yes
USE_AUTOTOOLS=	autoconf:261
GNU_CONFIGURE=	yes
USE_GNOME=	gtk20 pkgconfig

PORTDOCS=	AUTHORS README ChangeLog COPYING

post-extract:
	@${ECHO_CMD} ""
	@${ECHO_CMD} "****** Make sure you have mod_tls and mod_radius enabled in ftp/proftpd  ******"
	@${ECHO_CMD} ""
	@sleep 3
	@${CP} ${FILESDIR}/crypt.h ${WRKSRC}/src/

post-configure:
	@${REINPLACE_CMD} -e "s:\<crypt.h\>:\"crypt.h\":" ${WRKSRC}/src/functions.c

post-install:
.if !defined(NOPORTDOCS)
	@${MKDIR} ${DOCSDIR}
	@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
	@${INSTALL} -d ${PREFIX}/share/applications
	@${INSTALL_DATA} ${WRKSRC}/desktop/net-gproftpd.desktop \
		${PREFIX}/share/applications

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1