#
# $Id: Makefile.in,v 1.10 2003/05/11 18:31:45 hiroo Exp $
#
#
# FreeWnn is a network-extensible Kana-to-Kanji conversion system.
# This file is part of FreeWnn.
#
# Copyright Kyoto University Research Institute for Mathematical Sciences
# 1987, 1988, 1989, 1990, 1991, 1992
# Copyright OMRON Corporation. 1987, 1988, 1989, 1990, 1991, 1992, 1999
# Copyright ASTEC, Inc. 1987, 1988, 1989, 1990, 1991, 1992
# Copyright FreeWnn Project 1999, 2000, 2001, 2003
#
# Maintainer: FreeWnn Project <freewnn@tomo.gr.jp>
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
include @top_srcdir@/makerule.mk
top_builddir = ../..
INCLUDES = -I$(KWNNINCLUDESRC) -I$(TOP)
DEFINES = $(KWNNDEFINES) $(KWNNLANGDEF)
SRCS= strings.c sstrings.c bdic.c hindo.c gethinsi.c revdic.c pwd.c bcopy.c xutoj.c dic_atojis.c msg.c yincoding.c py_table.c zy_table.c server_env.c mkdir.c
SRCS2= getopt.c getopt1.c
OBJS= strings.o sstrings.o bdic.o hindo.o gethinsi.o revdic.o pwd.o bcopy.o xutoj.o dic_atojis.o msg.o yincoding.o py_table.o zy_table.o server_env.o mkdir.o
OBJS2= getopt.o getopt1.o
all::
includes::
.c.o:
$(RM) $@
$(CC) -c $(CFLAGS) $(_NOOP_) $*.c
clean::
all:: $(SRCS) $(OBJS) $(SRCS2) $(OBJS2)
includes:: $(SRCS) $(SRCS2)
strings.c: $(WNNETCSRC)/strings.c
$(RM) $@
$(LN) $? $@
includes:: strings.c
depend:: strings.c
sstrings.c: $(WNNETCSRC)/sstrings.c
$(RM) $@
$(LN) $? $@
includes:: sstrings.c
depend:: sstrings.c
bdic.c: $(WNNETCSRC)/bdic.c
$(RM) $@
$(LN) $? $@
includes:: bdic.c
depend:: bdic.c
hindo.c: $(WNNETCSRC)/hindo.c
$(RM) $@
$(LN) $? $@
includes:: hindo.c
depend:: hindo.c
gethinsi.c: $(WNNETCSRC)/gethinsi.c
$(RM) $@
$(LN) $? $@
includes:: gethinsi.c
depend:: gethinsi.c
revdic.c: $(WNNETCSRC)/revdic.c
$(RM) $@
$(LN) $? $@
includes:: revdic.c
depend:: revdic.c
pwd.c: $(WNNETCSRC)/pwd.c
$(RM) $@
$(LN) $? $@
includes:: pwd.c
depend:: pwd.c
bcopy.c: $(WNNETCSRC)/bcopy.c
$(RM) $@
$(LN) $? $@
includes:: bcopy.c
depend:: bcopy.c
xutoj.c: $(WNNETCSRC)/xutoj.c
$(RM) $@
$(LN) $? $@
includes:: xutoj.c
depend:: xutoj.c
dic_atojis.c: $(WNNETCSRC)/dic_atojis.c
$(RM) $@
$(LN) $? $@
includes:: dic_atojis.c
depend:: dic_atojis.c
msg.c: $(WNNETCSRC)/msg.c
$(RM) $@
$(LN) $? $@
includes:: msg.c
depend:: msg.c
yincoding.c: $(WNNETCSRC)/yincoding.c
$(RM) $@
$(LN) $? $@
includes:: yincoding.c
depend:: yincoding.c
py_table.c: $(WNNETCSRC)/py_table.c
$(RM) $@
$(LN) $? $@
includes:: py_table.c
depend:: py_table.c
zy_table.c: $(WNNETCSRC)/zy_table.c
$(RM) $@
$(LN) $? $@
includes:: zy_table.c
depend:: zy_table.c
server_env.c: $(WNNETCSRC)/server_env.c
$(RM) $@
$(LN) $? $@
includes:: server_env.c
depend:: server_env.c
mkdir.c: $(WNNETCSRC)/mkdir.c
$(RM) $@
$(LN) $? $@
includes:: mkdir.c
depend:: mkdir.c
getopt.c: $(WNNETCSRC)/getopt.c
$(RM) $@
$(LN) $? $@
includes:: getopt.c
depend:: getopt.c
getopt1.c: $(WNNETCSRC)/getopt1.c
$(RM) $@
$(LN) $? $@
includes:: getopt1.c
depend:: getopt1.c
depend:: .depend
clean::
$(RM) $(SRCS)
$(RM) $(SRCS2)
-$(RM) $(OBJS)
-$(RM) $(OBJS2)
syntax highlighted by Code2HTML, v. 0.9.1