SRCS = Makefile \
sys.h \
systype.c \
select.c \
tty.c \
termio.c \
regex.c \
hpux.c
OBJS = select.o \
tty.o \
termio.o \
regex.o \
hpux.o
all: libsys.a
libsys.a: $(OBJS)
ar rc libsys.a $(OBJS)
.c.o:
$(CC) -c $(CFLAGS) $*.c
select.o: sys.h select.c
tty.o: sys.h tty.c
termio.o: sys.h termio.c
regex.o: sys.h regex.c
hpux.o: sys.h hpux.c
tar: sys.tar
sys.tar:$(SRCS)
tar cfh sys.tar $(SRCS) ONEW_CONF.*
systype:systype.c
$(CC) $(CFLAGS) -o systype -DMAIN systype.c
syntax highlighted by Code2HTML, v. 0.9.1