# ----------------------------------------------------------------------------
# - Makefile -
# - afnix doc vol makefile -
# ----------------------------------------------------------------------------
# - This program is free software; you can redistribute it and/or modify -
# - it provided that this copyright notice is kept intact. -
# - -
# - This program is distributed in the hope that it will be useful, but -
# - without any warranty; without even the implied warranty of -
# - merchantability or fitness for a particular purpose. In not event shall -
# - the copyright holder be liable for any direct, indirect, incidental or -
# - special damages arising in any way out of the use of this software. -
# ----------------------------------------------------------------------------
# - copyright (c) 1999-2007 amaury darsch -
# ----------------------------------------------------------------------------
TOPDIR = ../../..
MAKDIR = $(TOPDIR)/cnf/mak
CONFFILE = $(MAKDIR)/afnix-conf.mak
RULEFILE = $(MAKDIR)/afnix-docs.mak
include $(CONFFILE)
# ----------------------------------------------------------------------------
# - project configuration -
# ----------------------------------------------------------------------------
DSTDIR = $(BLDDST)/doc/xml/vol
# ----------------------------------------------------------------------------
# - project rules -
# ----------------------------------------------------------------------------
# rule: all
# this rule is the default rule which does nothing
all: doc
.PHONY: all
# include: rule.mak
# this rule includes the platform dependant rules
include $(RULEFILE)
# rule: doc
# this rule prepare the documentation
doc:
@${MAKE} -C vol-0 doc
@${MAKE} -C vol-1 doc
@${MAKE} -C vol-2 doc
.PHONY: doc
# rule: distri
# this rule install the files in the distribution
distri:
@$(MKDIR) $(DSTDIR)
@$(CP) Makefile $(DSTDIR)
@${MAKE} -C vol-0 distri
@${MAKE} -C vol-1 distri
@${MAKE} -C vol-2 distri
.PHONY: distri
# rule: instdoc
# this rule install the documentation
instdoc:
@${MAKE} -C vol-0 instdoc
@${MAKE} -C vol-1 instdoc
@${MAKE} -C vol-2 instdoc
.PHONY: instdoc
# rule: clean
# This rule cleans the directories
clean::
@${MAKE} -C vol-0 clean
@${MAKE} -C vol-1 clean
@${MAKE} -C vol-2 clean
syntax highlighted by Code2HTML, v. 0.9.1