# ----------------------------------------------------------------------------
# - Makefile                                                                 -
# - afnix doc vol-1 makefile                                                 -
# ----------------------------------------------------------------------------
# - This program is  free software;  you can  redistribute it and/or  modify -
# - it provided that this copyright notice is kept intact.                   -
# -                                                                          -
# - This  program  is  distributed in the hope  that it  will be useful, but -
# - without  any   warranty;  without  even   the   implied    warranty   of -
# - merchantability  or fitness for a particular purpose. In not event shall -
# - the copyright holder be  liable for  any direct, indirect, incidental or -
# - special damages arising in any way out of the use of this software.      -
# ----------------------------------------------------------------------------
# - copyright (c) 1999-2007 amaury darsch                                    -
# ----------------------------------------------------------------------------

TOPDIR		= ../../../..
MAKDIR		= $(TOPDIR)/cnf/mak
CONFFILE	= $(MAKDIR)/afnix-conf.mak
RULEFILE	= $(MAKDIR)/afnix-docs.mak
include		  $(CONFFILE)

# ----------------------------------------------------------------------------
# - project configuration                                                    -
# ----------------------------------------------------------------------------

DSTDIR		= $(BLDDST)/doc/xml/vol/vol-1
MANSEC		= $(MANDIR)/man7
MANUAL		= vol-1.xml
MANMAN		= vol-1::afnix.7

# ----------------------------------------------------------------------------
# - project rules                                                            -
# ----------------------------------------------------------------------------

# rule: all
# this rule is the default rule which build the documentation

all: doc
.PHONY: doc

# include: rule.mak
# this rule includes the platform dependant rules

include $(RULEFILE)

# rule: distri
# this rule install the distribution

distri:
	@$(MKDIR) $(DSTDIR)
	@$(CP)    Makefile $(DSTDIR)
	@$(CP)    *.xml    $(DSTDIR)
.PHONY: distri

# rule: instdoc
# this rule install the documentation

instdoc: doc
	@$(MKDIR) $(DOCDIR)
	@$(CP)    $(XHTMAN) $(DOCDIR)
	@$(MKDIR) $(MANSEC)
	@$(CP)    $(MANMAN) $(MANSEC)
.PHONY: instdoc

# rule: clean
# this rule clean the directory

clean::
	@$(RM) $(XHTMAN)
	@$(RM) $(MANMAN)


syntax highlighted by Code2HTML, v. 0.9.1