# ----------------------------------------------------------------------------
# - Makefile                                                                 -
# - afnix prj makefile                                                       -
# ----------------------------------------------------------------------------
# - This program is  free software;  you can  redistribute it and/or  modify -
# - it provided that this copyright notice is kept intact.                   -
# -                                                                          -
# - This  program  is  distributed in the hope  that it  will be useful, but -
# - without  any   warranty;  without  even   the   implied    warranty   of -
# - merchantability  or fitness for a particular purpose. In not event shall -
# - the copyright holder be  liable for  any direct, indirect, incidental or -
# - special damages arising in any way out of the use of this software.      -
# ----------------------------------------------------------------------------
# - copyright (c) 1999-2007 amaury darsch                                    -
# ----------------------------------------------------------------------------

TOPDIR		= ..
MAKDIR		= $(TOPDIR)/cnf/mak
CONFFILE	= $(MAKDIR)/afnix-conf.mak
RULEFILE	= $(MAKDIR)/afnix-rule.mak
include		  $(CONFFILE)

# ----------------------------------------------------------------------------
# - project configuration                                                    -
# ----------------------------------------------------------------------------

DSTDIR		= $(BLDDST)/prj

# ----------------------------------------------------------------------------
# - project rules                                                            -
# ----------------------------------------------------------------------------

# rule: all
# this rule is the default rule which call the build rule

all: build
.PHONY: all

# include: rule.mak
# this rule includes the platform dependant rules

include $(RULEFILE)

# rule: build
# this rule build all source directories

build:
	@${MAKE} -C apx all
	@${MAKE} -C amd all
	@${MAKE} -C adp all
.PHONY: build

# rule: test
# this rule build and test all libraries

test:
	@${MAKE} -C apx test
	@${MAKE} -C amd test
	@${MAKE} -C adp test
.PHONY: test

# rule: doc
# this rule build the documentation

doc:
	@${MAKE} -C adp doc
	@${MAKE} -C amd doc
.PHONY: doc

# rule: distri
# this rule install the src distribution files

distri:
	@$(MKDIR) $(DSTDIR)
	@$(CP)    Makefile $(DSTDIR)
	@${MAKE}  -C apx distri
	@${MAKE}  -C amd distri
	@${MAKE}  -C adp distri
.PHONY: distri

# rule: install
# this rule install the distribution

install:
	@${MAKE} -C apx install
	@${MAKE} -C amd install
	@${MAKE} -C adp install
.PHONY: install

# rule: instdoc
# this rule install the documentation

instdoc:
	@${MAKE} -C adp instdoc
	@${MAKE} -C amd instdoc
.PHONY: instdoc

# rule: clean
# this rule clean all source directories

clean::
	@${MAKE} -C apx clean
	@${MAKE} -C amd clean
	@${MAKE} -C adp clean
.PHONY: clean


syntax highlighted by Code2HTML, v. 0.9.1