# ----------------------------------------------------------------------------
# - Makefile -
# - afnix axs example makefile -
# ----------------------------------------------------------------------------
# - This program is free software; you can redistribute it and/or modify -
# - it provided that this copyright notice is kept intact. -
# - -
# - This program is distributed in the hope that it will be useful, but -
# - without any warranty; without even the implied warranty of -
# - merchantability or fitness for a particular purpose. In not event shall -
# - the copyright holder be liable for any direct, indirect, incidental or -
# - special damages arising in any way out of the use of this software. -
# ----------------------------------------------------------------------------
# - copyright (c) 1999-2007 amaury darsch -
# ----------------------------------------------------------------------------
TOPDIR = ../../../..
MAKDIR = $(TOPDIR)/cnf/mak
CONFFILE = $(MAKDIR)/afnix-conf.mak
RULEFILE = $(MAKDIR)/afnix-rule.mak
include $(CONFFILE)
# ----------------------------------------------------------------------------
# - project configuration -
# ----------------------------------------------------------------------------
DSTDIR = $(BLDDST)/src/clt/axs/exp
# ----------------------------------------------------------------------------
# test definition overwrite -
# ----------------------------------------------------------------------------
AXSEXE = "axs"
AXSOPT = "-f assert"
TSTAXS = $(wildcard *.axs)
# ----------------------------------------------------------------------------
# - project rules -
# ----------------------------------------------------------------------------
# rule: all
# this rule is the default rule that compile the files
all: test
.PHONY: all
# include: rule.mak
# this rule includes the platform dependant rules
include $(RULEFILE)
# rule: test
# test the als files
$(TSTAXS) :
@$(AEXEC) -v --prefix=$(BLDDIR) \
--binexe=$(AXSEXE) --binopt=$(AXSOPT) $@
.PHONY: $(TSTAXS)
test: $(TSTAXS)
.PHONY: test
# rule: distri
# this rule install the exp distribution files
distri:
@$(MKDIR) $(DSTDIR)
@$(CP) Makefile $(DSTDIR)
@$(CP) *.tbl $(DSTDIR)
@$(CP) *.axs $(DSTDIR)
.PHONY: distri
# clean
# this rule clean for some local file
clean::
@$(RM) elements.htm elements.xss
syntax highlighted by Code2HTML, v. 0.9.1