# ----------------------------------------------------------------------------
# - Makefile                                                                 -
# - afnix modules makefile                                                   -
# ----------------------------------------------------------------------------
# - This program is  free software;  you can  redistribute it and/or  modify -
# - it provided that this copyright notice is kept intact.                   -
# -                                                                          -
# - This  program  is  distributed in the hope  that it  will be useful, but -
# - without  any   warranty;  without  even   the   implied    warranty   of -
# - merchantability  or fitness for a particular purpose. In not event shall -
# - the copyright holder be  liable for  any direct, indirect, incidental or -
# - special damages arising in any way out of the use of this software.      -
# ----------------------------------------------------------------------------
# - copyright (c) 2000-2007 amaury darsch                                    -
# ----------------------------------------------------------------------------

TOPDIR		= ../..
MAKDIR		= $(TOPDIR)/cnf/mak
CONFFILE	= $(MAKDIR)/afnix-conf.mak
RULEFILE	= $(MAKDIR)/afnix-rule.mak
include		  $(CONFFILE)

# ----------------------------------------------------------------------------
# - project configuration                                                    -
# ----------------------------------------------------------------------------

DSTDIR		= $(BLDDST)/src/mod

# ----------------------------------------------------------------------------
# - project rules                                                            -
# ----------------------------------------------------------------------------

# rule: all
# this rule is the default rule which call the build rule

all: build
.PHONY: all

# include: rule.mak
# this rule includes the platform dependant rules

include $(RULEFILE)

# rule: build
# this rule build all source directories

build:
	@${MAKE} -C gfx all
	@${MAKE} -C net all
	@${MAKE} -C nwg all
	@${MAKE} -C pim all
	@${MAKE} -C sio all
	@${MAKE} -C sps all
	@${MAKE} -C sys all
	@${MAKE} -C txt all
	@${MAKE} -C xml all
.PHONY: build

# rule: test
# this rule build and test all libraries

test:
	@${MAKE} -C gfx test
	@${MAKE} -C net test
	@${MAKE} -C nwg test
	@${MAKE} -C pim test
	@${MAKE} -C sio test
	@${MAKE} -C sps test
	@${MAKE} -C sys test
	@${MAKE} -C txt test
	@${MAKE} -C xml test
.PHONY: test

# rule: doc
# this rule builds the documentation

doc:
	@${MAKE} -C gfx doc
	@${MAKE} -C net doc
	@${MAKE} -C nwg doc
	@${MAKE} -C pim doc
	@${MAKE} -C sio doc
	@${MAKE} -C sps doc
	@${MAKE} -C sys doc
	@${MAKE} -C txt doc
	@${MAKE} -C xml doc
.PHONY: doc

# rule: distri
# this rule install the mod distribution files

distri:
	@$(MKDIR) $(DSTDIR)
	@$(CP)    Makefile $(DSTDIR)
	@${MAKE} -C gfx distri
	@${MAKE} -C net distri
	@${MAKE} -C nwg distri
	@${MAKE} -C pim distri
	@${MAKE} -C sio distri
	@${MAKE} -C sps distri
	@${MAKE} -C sys distri
	@${MAKE} -C txt distri
	@${MAKE} -C xml distri
.PHONY: distri

# rule: install
# this rule install the distribution

install:
	@${MAKE} -C gfx install
	@${MAKE} -C net install
	@${MAKE} -C nwg install
	@${MAKE} -C pim install
	@${MAKE} -C sio install
	@${MAKE} -C sps install
	@${MAKE} -C sys install
	@${MAKE} -C txt install
	@${MAKE} -C xml install
.PHONY: install

# rule: instdoc
# this rule install the distribution

instdoc:
	@${MAKE} -C gfx instdoc
	@${MAKE} -C net instdoc
	@${MAKE} -C nwg instdoc
	@${MAKE} -C pim instdoc
	@${MAKE} -C sio instdoc
	@${MAKE} -C sps instdoc
	@${MAKE} -C sys instdoc
	@${MAKE} -C txt instdoc
	@${MAKE} -C xml instdoc
.PHONY: instdoc

# rule: clean
# this rule clean all source directories

clean::
	@${MAKE} -C gfx clean
	@${MAKE} -C net clean
	@${MAKE} -C nwg clean
	@${MAKE} -C pim clean
	@${MAKE} -C sio clean
	@${MAKE} -C sps clean
	@${MAKE} -C sys clean
	@${MAKE} -C txt clean
	@${MAKE} -C xml clean
.PHONY: clean


syntax highlighted by Code2HTML, v. 0.9.1