# ----------------------------------------------------------------------------
# - Makefile -
# - afnix:sys module example makefile -
# ----------------------------------------------------------------------------
# - This program is free software; you can redistribute it and/or modify -
# - it provided that this copyright notice is kept intact. -
# - -
# - This program is distributed in the hope that it will be useful, but -
# - without any warranty; without even the implied warranty of -
# - merchantability or fitness for a particular purpose. In not event shall -
# - the copyright holder be liable for any direct, indirect, incidental or -
# - special damages arising in any way out of the use of this software. -
# ----------------------------------------------------------------------------
# - copyright (c) 2000-2007 amaury darsch -
# ----------------------------------------------------------------------------
TOPDIR = ../../../..
MAKDIR = $(TOPDIR)/cnf/mak
CONFFILE = $(MAKDIR)/afnix-conf.mak
RULEFILE = $(MAKDIR)/afnix-rule.mak
include $(CONFFILE)
# ----------------------------------------------------------------------------
# project configurationn -
# ----------------------------------------------------------------------------
DSTDIR = $(BLDDST)/src/mod/sys/exp
# ----------------------------------------------------------------------------
# test definition -
# ----------------------------------------------------------------------------
TESTALS = $(wildcard *.als)
# ----------------------------------------------------------------------------
# - project rules -
# ----------------------------------------------------------------------------
# rule: all
# this rule is the default rule which call the test rule
all:
@exit 0
.PHONY: all
# include: rule.mak
# this rule includes the platform dependant rules
include $(RULEFILE)
# rule: distri
# this rule install the tst distribution files
distri:
@$(MKDIR) $(DSTDIR)
@$(CP) Makefile $(DSTDIR)
@$(CP) *.als $(DSTDIR)
.PHONY: distri
syntax highlighted by Code2HTML, v. 0.9.1