# Build runtime library for Dylan under Win32
OPEN_DYLAN_RELEASE_BIN=$(OPEN_DYLAN_RELEASE_INSTALL)\bin
OPEN_DYLAN_RELEASE_INCLUDE=$(OPEN_DYLAN_RELEASE_INSTALL)\include
OPEN_DYLAN_RELEASE_LIB=$(OPEN_DYLAN_RELEASE_INSTALL)\lib
OPEN_DYLAN_USER_BIN=$(OPEN_DYLAN_USER_INSTALL)\bin
OPEN_DYLAN_USER_INCLUDE=$(OPEN_DYLAN_USER_INSTALL)\include
OPEN_DYLAN_USER_LIB=$(OPEN_DYLAN_USER_INSTALL)\lib
APPVER = 4.0
TARGETOS = BOTH
!include <win32.mak>
!if !defined(NODEBUG) && !defined(PROFILE) && !defined(TUNE)
cdebug = $(cdebug)
!endif
CC = $(cc)
LINKLIB = $(implib) /nologo /out:
CFLAGS = $(cflags) $(cvarsmt) $(cdebug) /I$(OPEN_DYLAN_RELEASE_INCLUDE) $(OPEN_DYLAN_C_FLAGS)
OBJS = run-time.obj debug-print.obj
LIBFILE = run-time.lib
$(LIBFILE): $(OBJS)
$(LINKLIB)$(LIBFILE) $(OBJS)
install: $(LIBFILE)
pushd $(OPEN_DYLAN_USER_LIB) & del /q /f $(LIBFILE) & popd
copy $(LIBFILE) $(OPEN_DYLAN_USER_LIB)
pushd $(OPEN_DYLAN_USER_INCLUDE) & del /q /f run-time.h & popd
copy run-time.h $(OPEN_DYLAN_USER_INCLUDE)
pushd $(OPEN_DYLAN_USER_BIN) & del /q /f ccl-linker.script & popd
copy win32-ccl-linker.script $(OPEN_DYLAN_USER_BIN)\ccl-linker.script
clean:
del /q /f $(OBJS) $(LIBFILE)
syntax highlighted by Code2HTML, v. 0.9.1