# New ports collection makefile for:    libvmime
# Date created:				September 17, 2005
# Whom:					delphij@FreeBSD.org
#
# $FreeBSD: ports/mail/libvmime/Makefile,v 1.8 2007/12/14 22:04:22 delphij Exp $
#

PORTNAME=	libvmime
PORTVERSION=	0.8.1
PORTREVISION=	3
CATEGORIES=	mail
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=	vmime

MAINTAINER=	delphij@FreeBSD.org
COMMENT=	An all-in-one Internet mail library

LIB_DEPENDS+=	gnutls.13:${PORTSDIR}/security/gnutls
LIB_DEPENDS+=	gsasl.11:${PORTSDIR}/security/gsasl

USE_BZIP2=	yes
USE_GMAKE=	yes
USE_ICONV=	yes
USE_GCC=	3.3+
GNU_CONFIGURE=	yes
USE_LDCONFIG=	yes

CFLAGS+=	-I${LOCALBASE}/include
LDFLAGS+=	-L${LOCALBASE}/lib

.ifndef	DEBUG
CONFIGURE_ARGS+=--disable-debug
.endif

CONFIGURE_ENV+=	CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"

DOCSDIR=	${PREFIX}/share/doc/vmime

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1