# Generated automatically from Makefile.in by configure.
# Copyright (C) 1998-2003 by the Free Software Foundation, Inc.
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# as published by the Free Software Foundation; either version 2
# of the License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
# NOTE: Makefile.in is converted into Makefile by the configure script
# in the parent directory. Once configure has run, you can recreate
# the Makefile by running just config.status.
# Variables set by configure
srcdir= .
bindir= ${exec_prefix}/bin
prefix= /usr/local/mailman
exec_prefix= ${prefix}
DESTDIR=
CC= cc
CHMOD= @CHMOD@
INSTALL= /usr/bin/install -c -o root -g wheel
DEFS= -DHAVE_STRERROR=1 -DHAVE_SETREGID=1 -DHAVE_SYSLOG=1 -DSTDC_HEADERS=1 -DHAVE_SYSLOG_H=1 -DGETGROUPS_T=gid_t -DHAVE_VSNPRINTF=1
# Customizable but not set by configure
OPT= -g -O2
CFLAGS= $(OPT) $(DEFS)
PACKAGEDIR= $(prefix)/Mailman/Bouncers
SHELL= /bin/sh
MODULES= *.py
# Modes for directories and executables created by the install
# process. Default to group-writable directories but
# user-only-writable for executables.
DIRMODE= 775
EXEMODE= 755
FILEMODE= 644
INSTALL_PROGRAM=$(INSTALL) -m $(EXEMODE)
# Rules
all:
install:
for f in $(MODULES); \
do \
$(INSTALL) -m $(FILEMODE) $(srcdir)/$$f $(DESTDIR)$(PACKAGEDIR); \
done
finish:
clean:
distclean:
-rm *.pyc
-rm Makefile
# Local Variables:
# indent-tabs-mode: t
# End:
syntax highlighted by Code2HTML, v. 0.9.1