# Ports collection makefile for:  pear-MIME_Type
# Date created:			  18 April 2005
# Whom:				  Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
#
# $FreeBSD: ports/mail/pear-MIME_Type/Makefile,v 1.4 2006/09/23 00:23:28 linimon Exp $
#

PORTNAME=	MIME_Type
PORTVERSION=	1.0.0
CATEGORIES=	mail www pear

MAINTAINER=	ports@FreeBSD.org
COMMENT=	PEAR class for dealing with MIME types

BUILD_DEPENDS=	${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS=	${BUILD_DEPENDS}

LATEST_LINK=	pear-${PORTNAME}
OPTIONS=	PEAR_SYSTEM_COMMAND "PEAR::System_Command support" off

CATEGORY=	MIME
FILES=		Type.php Type/Parameter.php
EXAMPLES=	example.php
_EXAMPLESDIR=	.

post-extract:
	@${MKDIR} ${WRKSRC}/Type
	@${MV} ${WRKSRC}/Parameter.php ${WRKSRC}/Type

.include <bsd.port.pre.mk>

.if defined(WITH_PEAR_SYSTEM_COMMAND)
RUN_DEPENDS+=	${PEARDIR}/System/Command.php:${PORTSDIR}/devel/pear-System_Command
.endif

.include "${PORTSDIR}/devel/pear/bsd.pear.mk"

post-patch:
.for file in ${FILES}
	@${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/${file}
	@${REINPLACE_CMD} -e "s|@package@|${PORTNAME}|" ${WRKSRC}/${file}
.endfor
	@${REINPLACE_CMD} -e "s|@doc_dir@|${EXAMPLESDIR}|" ${WRKSRC}/${EXAMPLES}

.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1