# Ports collection makefile for: gem-actionmailer
# Date created: 27 May 2005
# Whom: Jonathan Weiss (<jw@innerewut.de>)
#
# $FreeBSD: ports/mail/rubygem-actionmailer/Makefile,v 1.11 2007/12/03 23:26:43 miwi Exp $
PORTNAME= actionmailer
PORTVERSION= 1.3.6
CATEGORIES= mail rubygems
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jw@innerewut.de
COMMENT= Easy email delivery and testing for Ruby
BUILD_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/actionpack-1.13.6.gemspec:${PORTSDIR}/www/rubygem-actionpack
RUN_DEPENDS= ${BUILD_DEPENDS}
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
| ${SED} -E \
's,.*share/nls/.+$$,,g \
;s,^${GEM_CACHE}$$,%%GEM_CACHE%%,g \
;s,${GEM_DOC_DIR}(/.+)?$$,%%GEM_DOC_DIR%%\1,g \
;s,${GEM_LIB_DIR}(/.+)?$$,%%GEM_LIB_DIR%%\1,g \
;s,^${GEM_SPEC}$$,%%GEM_SPEC%%,g \
;s,^${GEMS_BASE_DIR}/(.+)$$,\1,g \
;s,^@dirrm (${SPEC_DIR}|${GEMS_DIR}|lib/ruby).*$$,,g \
' | ${TR} -s '\n') > temp-pkg-plist
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>
syntax highlighted by Code2HTML, v. 0.9.1