# New ports collection makefile for:	fung-calc
# Date created:				10.06.2003
# Whom:					Kirill Ponomarew <ponomarew@oberon.net>
#
# $FreeBSD: ports/math/fung-calc/Makefile,v 1.24 2007/05/19 20:14:57 flz Exp $

PORTNAME=	fung-calc
PORTVERSION=	1.3.2b
PORTREVISION=	8
CATEGORIES=	math kde
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=	${PORTNAME}

MAINTAINER=	markus@FreeBSD.org
COMMENT=	Advanced graphic calculator

LIB_DEPENDS=	glut.4:${PORTSDIR}/graphics/libglut

USE_KDELIBS_VER=3
USE_GL=		yes
USE_GMAKE=	yes
INSTALLS_SHLIB=	yes
USE_AUTOTOOLS=	libtool:15
CONFIGURE_ENV+=	LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"

pre-configure:
	@${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
		${WRKSRC}/configure

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1