# New ports collection makefile for:   ocaml-ocamlgraph
# Date created:        25 May 2004
# Whom:                Joseph Koshy <jkoshy@freebsd.org>
#
# $FreeBSD: ports/math/ocaml-ocamlgraph/Makefile,v 1.4 2007/05/19 20:15:08 flz Exp $
#

PORTNAME=	ocamlgraph
PORTVERSION=	0.95
PORTREVISION=	1
CATEGORIES=	math
MASTER_SITES=	http://www.lri.fr/~filliatr/ftp/ocamlgraph/
PKGNAMEPREFIX=	ocaml-
DISTNAME=	${PORTNAME}-${PORTVERSION}

MAINTAINER=	jkoshy@freebsd.org
COMMENT=	Graph manipulation library for OCaml

BUILD_DEPENDS=	ocamlc:${PORTSDIR}/lang/ocaml
RUN_DEPENDS=	ocaml:${PORTSDIR}/lang/ocaml

USE_GMAKE=	yes

HAS_CONFIGURE=	yes
CONFIGURE_ARGS+= --prefix=${PREFIX}

ALL_TARGET=	all
.ifndef NOPORTDOCS
ALL_TARGET+=	doc
.endif

.ifndef NOPORTDOCS
post-install:
	${MKDIR} ${DOCSDIR}
	cd ${WRKSRC}/doc; ${INSTALL_DATA} * ${DOCSDIR}
.endif

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1