# New ports collection makefile for:	Math-Symbolic
# Date created:				15 May 2006
# Whom:					Aaron Dalton <aaron@FreeBSD.org>
#
# $FreeBSD: ports/math/p5-Math-Symbolic/Makefile,v 1.5 2007/09/08 01:01:39 linimon Exp $
#

PORTNAME=	Math-Symbolic
PORTVERSION=	0.507
CATEGORIES=	math perl5
MASTER_SITES=	${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR=	Math
PKGNAMEPREFIX=	p5-

MAINTAINER=	aaron@FreeBSD.org
COMMENT=	Symbolic calculations

BUILD_DEPENDS=	${SITE_PERL}/Memoize.pm:${PORTSDIR}/devel/p5-Memoize \
		${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
		${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
RUN_DEPENDS=	${BUILD_DEPENDS}

MAN3=	Math::Symbolic.3 \
	Math::Symbolic::AuxFunctions.3 \
	Math::Symbolic::Base.3 \
	Math::Symbolic::Compiler.3 \
	Math::Symbolic::Constant.3 \
	Math::Symbolic::Custom.3 \
	Math::Symbolic::Custom::Base.3 \
	Math::Symbolic::Custom::DefaultDumpers.3 \
	Math::Symbolic::Custom::DefaultMods.3 \
	Math::Symbolic::Custom::DefaultTests.3 \
	Math::Symbolic::Derivative.3 \
	Math::Symbolic::ExportConstants.3 \
	Math::Symbolic::MiscAlgebra.3 \
	Math::Symbolic::MiscCalculus.3 \
	Math::Symbolic::Operator.3 \
	Math::Symbolic::Parser.3 \
	Math::Symbolic::Parser::Precompiled.3 \
	Math::Symbolic::Variable.3 \
	Math::Symbolic::VectorCalculus.3 \
	Math::precompile_recdescent_grammar.3

PERL_CONFIGURE=	yes

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1