# New ports collection makefile for:	xppaut
# Date created:		3 September 2004
# Whom:			Stephen Montgomery-Smith <stephen@math.missouri.edu>
#
# $FreeBSD: ports/math/xppaut/Makefile,v 1.5 2007/05/19 20:15:27 flz Exp $
#

PORTNAME=	xppaut
PORTVERSION=	5.96
PORTREVISION=	1
CATEGORIES=	math graphics
MASTER_SITES=	http://www.math.pitt.edu/~bard/bardware/
DISTNAME=	${PORTNAME}${PORTVERSION}

MAINTAINER=	stephen@math.missouri.edu
COMMENT=	Graphical tool for solving differential equations, etc

MAN1=		xppaut.1
USE_X_PREFIX=	yes
USE_XORG=	xbitmaps
MAKE_ARGS=	CC="${CC}"

WRKSRC=		${WRKDIR}

post-build:
	${CHMOD} a+r ${WRKSRC}/xppaut.1

pre-configure:
.if !defined(NOPORTDOCS)
	@${REINPLACE_CMD} -e "s|# PORTDOCS||" ${WRKSRC}/Makefile
.endif

post-patch:
	@(cd ${WRKSRC} && ${REINPLACE_CMD} -e "s|gcc|${CC}|" Makefile libI77/Makefile cvodesrc/Makefile mkavi/Makefile)

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1