VERSION = 1.3
PKGNAME = chord2html
DIR = $(PKGNAME)-$(VERSION)
PODFLAGS= --section=1 --release="Version $(VERSION)" --center=" "
DFILES = Makefile README COPYING AUTHORS Changelog chord2html \
chord2html.css chord2html.1 chord2html.html chord2html.pod
.SUFFIXES: .html .pod .1
.pod.html:
pod2html $< > $*.html
.pod.1:
pod2man $(PODFLAGS) $< > $*.1
all: docs
docs: chord2html.1 chord2html.html
clean:
rm -f *~~
dist: docs
rm -Rf $(DIR)
mkdir $(DIR)
cp $(DFILES) $(DIR)
tar cvf - $(DIR) | gzip -9c > $(DIR).tar.gz
rm -Rf $(DIR)
chord2html.1 chord2html.html: chord2html.pod Makefile