# 
#  ----------------------------------------------------------------------
#  CcXstream Makefile
#  ----------------------------------------------------------------------
#
#  Copyright (c) 2002-2003 by PuhPuh
#  
#  This code is copyrighted property of the author.  It can still
#  be used for any non-commercial purpose following conditions:
#  
#      1) This copyright notice is not removed.
#      2) Source code follows any distribution of the software
#         if possible.
#      3) Copyright notice above is found in the documentation
#         of the distributed software.
#  
#  Any express or implied warranties are disclaimed.  Author is
#  not liable for any direct or indirect damages caused by the use
#  of this software.
#
#  ----------------------------------------------------------------------
#

CFLAGS+=-I. -g
LDFLAGS+=-lreadline -ltermcap

all: ccxstream ccxtest

ccxstream: ccxstream.o ccxfile.o ccutil.o ccbuffer.o ccdebug.o ccxmltrans.o ccxencode.o

ccxtest: ccxtest.o ccxclient.o ccxclientconn.o ccutil.o ccbuffer.o ccdebug.o ccxmltrans.o ccxencode.o ccxdiscover.o

clean:
	rm -f ccxstream ccxtest *.o core *~

# eof (Makefile)


syntax highlighted by Code2HTML, v. 0.9.1