# New ports collection makefile for:	net/csync2
# Date created:				16 May 2007
# Whom:					Aaron Dalton <aaron@FreeBSD.org>
#
# $FreeBSD: ports/net/csync2/Makefile,v 1.4 2007/07/01 08:56:09 novel Exp $
#

PORTNAME=	csync2
PORTVERSION=	1.33
PORTREVISION=	1
CATEGORIES=	net
MASTER_SITES=	http://oss.linbit.com/csync2/ \
		http://people.freebsd.org/~aaron/distfiles/

MAINTAINER=	aaron@FreeBSD.org
COMMENT=	A cluster synchronization tool

LIB_DEPENDS=	rsync.1:${PORTSDIR}/net/librsync \
		tasn1.3:${PORTSDIR}/security/libtasn1 \
		gnutls.13:${PORTSDIR}/security/gnutls \
		sqlite.2:${PORTSDIR}/databases/sqlite2 \
		gcrypt.13:${PORTSDIR}/security/libgcrypt \
		gpg-error.0:${PORTSDIR}/security/libgpg-error

BROKEN=		Installs config file in /etc

MAN1=	csync2.1

GNU_CONFIGURE=	yes
CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ENV+=	LDFLAGS="-L${LOCALBASE}/lib"

PLIST_FILES=	sbin/csync2 \
		sbin/csync2-compare

post-install:
	@${CAT} ${PKGMESSAGE}

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1