# New ports collection makefile for:    libtnl
# Date created:         26 Jan 2006
# Whom:                 aaron@FreeBSD.org
#
# $FreeBSD: ports/net/libtnl/Makefile,v 1.2 2007/10/04 20:31:56 linimon Exp $
#

PORTNAME=	libtnl
PORTVERSION=	1.5.0
CATEGORIES=	net devel
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR=	opentnl
DISTNAME=	tnl-${PORTVERSION}-source

MAINTAINER=	aaron@FreeBSD.org
COMMENT=	A robust, secure, easy to use cross-platform C++ networking API

WRKSRC=		${WRKDIR}/tnl/tnl
USE_LDCONFIG=	yes
ONLY_FOR_ARCHS=	i386

post-extract:
	@${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile

pre-install:
	${MKDIR} ${PREFIX}/include/tnl

.include <bsd.port.pre.mk>

.if ${OSVERSION} >= 700042
BROKEN=		Does not compile with GCC 4.2
.endif

.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1