# New ports collection makefile for: p5-POE-Component-Client-Traceroute
# Date created: 2006-08-09
# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
#
# $FreeBSD: ports/net/p5-POE-Component-Client-Traceroute/Makefile,v 1.3 2006/10/02 03:07:44 clsung Exp $
#
PORTNAME= POE-Component-Client-Traceroute
PORTVERSION= 0.21
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= POE
PKGNAMEPREFIX= p5-
MAINTAINER= tjs@cdpa.nsysu.edu.tw
COMMENT= A non-blocking traceroute client
RUN_DEPENDS= p5-POE>=0.11:${PORTSDIR}/devel/p5-POE
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= POE::Component::Client::Traceroute.3
post-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500702
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
.endif
.include <bsd.port.post.mk>
syntax highlighted by Code2HTML, v. 0.9.1