CFLAGS=-Wall
repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o
	g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o

repeater.o: repeater.cpp
	g++ $(CFLAGS) -c repeater.cpp

repeaterproc.o: repeaterproc.cpp
	g++ $(CFLAGS) -c repeaterproc.cpp

openbsd_stringfuncs.o: openbsd_stringfuncs.cpp
	g++ $(CFLAGS) -c openbsd_stringfuncs.cpp

iniparser.o: iniparser.cpp
	g++ $(CFLAGS) -c iniparser.cpp

clean:
	rm -f *.o repeater


syntax highlighted by Code2HTML, v. 0.9.1