# New ports collection makefile for:    tryst
# Date created:         18 Dec 2006
# Whom:                 dirk.meyer@dinoex.sub.org
#
# $FreeBSD: ports/net/tryst/Makefile,v 1.7 2007/05/19 20:19:07 flz Exp $
#

PORTNAME=	tryst
PORTVERSION=	1.0.8
PORTREVISION=	2
CATEGORIES=	net gnustep
MASTER_SITES=	${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=	dinoex
DISTNAME=	tryst-108pl6
EXTRACT_SUFX=	.tgz

MAINTAINER=	dinoex@FreeBSD.org
COMMENT=	Implementation of Apples Bonjour for GNUstep

LIB_DEPENDS=	dns_sd:${PORTSDIR}/net/mDNSResponder

USE_GNUSTEP=	yes
USE_GNUSTEP_PREFIX=	yes
USE_GNUSTEP_BACK=	yes
USE_GNUSTEP_BUILD=	yes
USE_GNUSTEP_INSTALL=	yes
USE_GNUSTEP_LDCONFIG=	${GNUSTEP_LOCAL_LIBRARIES}

WRKSRC=		${WRKDIR}/Tryst-108.pl6

.if defined(FETCH_MAKESUM)
MASTER_SITES=	http://gnustep.dyndns.org/Downloads/Frameworks/
.endif

# to build on 64bit
post-patch:
	${REINPLACE_CMD} -e 's|-Werror||' \
		${WRKSRC}/GNUmakefile.preamble

.include <bsd.port.mk>


syntax highlighted by Code2HTML, v. 0.9.1