##############################################################################
# This file is part of the VChat conference server distribution.             #
#                                                                            #
# Copyright (c) 1993 - 2006 Andreas S. Wetzel                                #
# All rights reserved.                                                       #
#                                                                            #
# The contents of this file are subject to the terms of the GNU General      #
# Public License (GPL), version 2 only ("the License") as published by the   #
# Free Software Foundation.                                                  #
#                                                                            #
# This Software comes with ABSOLUTELY NO WARRANTY.                           #
# See the License for more details. You should have received a copy of the   #
# License along with this distribution; See the file COPYING. If not, write  #
# to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,    #
# Boston, MA 02110-1301 USA.                                                 #
##############################################################################
 
# $Id: Makefile.in,v 1.6 2006/08/20 17:11:02 mickey Exp $

SHELL		= @SHELL@
INSTALL		= @INSTALL@
RM		= @RM@
AUTOHEADER	= autoheader259
AUTOCONF	= autoconf259

prefix		= @prefix@
exec_prefix	= @exec_prefix@
srcdir		= @srcdir@

SUBDIRS		= src man

SUBTARGS	= all depend installdirs install uninstall clean

DISTCLNFILES	= config.log \
		  config.status \
		  config.h \
		  stamp-h \
		  Makefile \
		  src/Makefile \
		  src/vserver/Makefile \
		  src/vchatctl/Makefile \
		  man/Makefile \
		  man/vserver.acl.5 \
		  man/vserver.8 \
		  man/vchatctl.8

DEVELCLNFILES	= configure \
		  configure.lineno \
		  config.h.in \
		  config.h.in~

.NOTPARALLEL:

$(SUBTARGS):
		@for i in $(SUBDIRS); do \
			cd $$i ; \
			echo "---------------> $$i ($@)" ; \
			$(MAKE) $@ ; \
			cd .. ; \
		done

$(srcdir)/configure:	configure.ac aclocal.m4 version.m4
		cd $(srcdir) && $(AUTOCONF)

$(srcdir)/config.h.in:	stamp-h.in

$(srcdir)/stamp-h.in:	configure.ac aclocal.m4 version.m4
		cd $(srcdir) && $(AUTOHEADER)
		echo timestamp > $(srcdir)/stamp-h.in

config.h:	stamp-h

stamp-h:	config.h.in config.status
		./config.status

Makefile:	Makefile.in config.status
		./config.status

config.status:	configure
		./config.status --recheck

distclean:
		(cd $(srcdir) ; $(MAKE) clean)
		$(RM) -f $(DISTCLNFILES)

develclean:	distclean
		$(RM) -Rf autom4te.cache
		$(RM) -f $(DEVELCLNFILES)

.PHONY:		all depend installdirs install uninstall clean distclean develclean


syntax highlighted by Code2HTML, v. 0.9.1